Just a minor observation about libubsan0 version http://security.ubuntu.com/ubuntu/pool/main/g/gcc-5/libubsan0_5.4.0-6ubuntu1~16.04.10_amd64.deb

Asked by John Franks on 2018-11-12

My apologies if I am wrong, but the following two lines appear to be in err by 1 digit the number '1':

Where is says:
libc6 (>= 2.4) [amd64, armhf, i386]
libc6 (>= 2.6) [powerpc]

It should really say:

https://packages.ubuntu.com/xenial/libubsan0
libc6 (>= 2.14) [amd64, armhf, i386]
libc6 (>= 2.16) [powerpc]

The version of libc is only up to about 2.23 here so it just seems odd that it would be 2.4 and 2.6, pretty sure it's 2.14 and 2.16.

Again, if I'm wrong, my apologies. One thing for certain is that the versions of libubsan0, libquadmath, libtsan, etc.. are not as high as 2.4, so I think I'm probably right.

Thank you for your attention.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcc-5 Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-11-13
Last query:
2018-11-13
Last reply:
2018-11-12
Best Manfred Hampl (m-hampl) said : #1

I assume that you refer to the information shown at https://packages.ubuntu.com/xenial/libubsan0
The web site packages.ubuntu.com is just a platform to allow searching for packages and only copies information from elsewhere.

You better look at launchpad.net/ubuntu but even there I see identical information, see e.g.
https://launchpad.net/ubuntu/xenial/amd64/libubsan0/5.4.0-6ubuntu1~16.04.10
https://launchpad.net/ubuntu/xenial/powerpc/libubsan0/5.4.0-6ubuntu1~16.04.10

Why do you think that the information is wrong and should be 2.14 instead of 2.4 and 2.16 instead of 2.6?
The information "libc6 (>= 2.4) [amd64, armhf, i386]" means that the libubsan0 package depends on the presence of the libc6 package in any version greater or equal 2.4
Do you have any information about an incompatibility which requires libc6 greater or equal 2.14?
The current libc6 version 2.23 fulfills both >= 2.4 and >= 2.14

Please note that version numbers do not have a "alphabetical" sorting ("2.1" - "2.10" - "2.11" - ... - "2.19" - "2.2" - "2.20" - "2.21"), but a numeric sort order, e.g. 2.1 - 2.2 - 2.3 - 2.4 - 2.5 - 2.6 - 2.7 - 2.8 - 2.9 - 2.10 - 2.11 - 2.12 - 2.13 - 2.14 - 2.15 - 2.16 - 2.17 - 2.18 - 2.19 - 2.20 - 2.21 - 2.22 - 2.23 - 2.24 - 2.25 - 2.26 - 2.27 - 2.28

John Franks (linuxmachinist) said : #2

Dear Manfred Hampl:

Forgive my misunderstanding alphabetic vs. numeric order of the packages.

I did realize that the information from launchpad (which is using developer's builds) was PROBABLY correct - and I DID suffer some lexicographic versus numeric confusion briefly. I say PROBABLY because I knew that the packages vintage 2.23 were working fine on my Linux machines that use them, with the stuff that depended on 2.4 and 2.6 but I kept scratching my head as I thought that 2.4 was > 2.23, and that the repositories may have had a typo.. So thanks for correcting my misunderstanding.

Sorry I was misinformed and it's good to know everything is fine in the repositories.
Thanks again.

John Franks (linuxmachinist) said : #3

Thanks Manfred Hampl, that solved my question.