how to install gcc 4.8.2 when your ubuntu already on it gcc 4.6

Asked by belal medhat on 2013-11-04

i am new to ubuntu and to linux
i want to install gcc 4.8.2 for c,c++,java because its new features in openmp 4 support
i have downloaded ubuntu 12.04.3 lts and setup it using vmwareplayer and oracle virtual box and both working
i opened the terminal and wrote gcc --version then i get 4.6 gcc installed by default on my ubuntu
i want to know hot to update gcc to 4.8.2 and to the newest release

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gcc-4.8 Edit question
Assignee:
No assignee Edit question
Last query:
2013-11-04
Last reply:
2013-11-05
Thomas Krüger (thkrueger) said : #1

You can use a PPA like https://launchpad.net/~ubuntu-toolchain-r/+archive/test. Read the page for instructions!
…or you install Ubuntu 13.10 which has gcc-4.8.1 in it's repositories.

Can you help with this problem?

Provide an answer of your own, or ask belal medhat for more information if necessary.

To post a message you must log in.