need a reset button

Asked by Dave on 2009-04-29

I am a moderately frequent user of gcalctool, and I am a SW programmer, so I like to use the Bit Editor feature and related.

Somehow, gcalctool got in a state where the accuracy was set to 0.

I could not figure out why 3/2 = 2 !!! Rather, I figured I knew what was happening, but I didn't know how it got to that state or how to clear it.

I eventually found the "Acc" pulldown and fixed the problem. But that is not intuitive, IMHO.

Especially since that pulldown is not available in any mode except Scientific.

I think the easiest thing for most users would be a "reset to defaults" option that would get everything back to normal.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcalctool Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2009-04-30
Last query:
2009-04-30
Last reply:
2009-04-30

I'd submit this as a bug and it will then get moved to the feature request section

Sam_ (and-sam) said : #2

Reset gcalctool with gconf-editor via terminal:
gconftool-2 --recursive-unset /apps/gcalctool

Or open gconf-editor and reset manually. (path as above /apps/gcalctool)
http://library.gnome.org/users/gconf-editor/2.22/getting-started.html.en

Reference:
man gcalctool

Dave (daves73+launchpad) said : #3

Thanks actionparsnip, that solved my question.

Dave (daves73+launchpad) said : #4

I opted to submit a bug.
https://bugs.launchpad.net/ubuntu/+source/gcalctool/+bug/369904

The command line options are good to know, but not intuitive, and general users will not want to search around for that type of solution.