Ubuntu

E misinterpreted in hex mode

Asked by Jon Povey on 2008-04-21

In HEX mode, typed characters are not interpreted as hexadecimal digits.

Using the default calculator in ubuntu 7.10:
View -> scientific
click hex
enter 1e2 (for example)
click decimal gives 100.

It seems that lowecase letters are interpreted as special functions (I tried entering 1FFFF and got 1FunFunFunFun). Uppercase letters seem to work?

All upper or lowercase ABCDEF should be interpreted as hex digits in hex mode. I first tried a calculation with just an "e" in it and got very weird results, violating the principle of least surprise.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcalctool Edit question
Assignee:
No assignee Edit question
Solved by:
Bhavani Shankar
Solved:
2008-04-23
Last query:
2008-04-23
Last reply:
2008-04-23
Jon Povey (jon-povey) said : #1

Sorry, I should probably have reported this as a bug rather than "Question". I arrived here from the "get help online" menu option in the software.

Bhavani Shankar (bhavi) said : #2

Hello

click on the letters on the calculator GUI (Ex click ABCDEF letters on the calculator will yeild 11259375 in decimal)

Have a try..

Hope it helps

Bhavani Shankar.

Jon Povey (jon-povey) said : #3

Yes, I am aware of the buttons thanks. I was trying to report what I believe to be a broken user interface, rather than looking for a workaround.

Best Bhavani Shankar (bhavi) said : #4

Hmm working for me though...

you can do one thing.. You can report the problem with apport (help -> report a problem).

and please provide as much info as possible so that the bugsquad guys can help you better

and please close this question before doing so

Regards

Bhavani Shankar.

Jon Povey (jon-povey) said : #5

Thanks Bhavani Shankar, that solved my question.

Jon Povey (jon-povey) said : #6

(not)