gcaltool binary is missing from the package in 14.04

Asked by Gil Shwartz on 2015-07-26

In 12.04 the gcalctool package includes a binary by that name. The 14.04 package seem to only include doc files and not the actual program itself (nor man pages). Is this by some design or a regression?

Launch calculator using the XF86Calculator key uses this command. It worked just fine in 12.04 but fails in 14.04.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gcalctool Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2015-07-26
Last query:
2015-07-26
Last reply:
2015-07-26

I suggest you report a bug

Gil Shwartz (gil-shwartz) said : #2

Thanks actionparsnip, that solved my question.

I think that the packagename gcalctool from Ubuntu 12.04 LTS has simply changed to gnome-calculator in Ubuntu 14.04 LTS.

I came to that conclusion after comparing the following filelists:

http://packages.ubuntu.com/precise/amd64/gcalctool/filelist

http://packages.ubuntu.com/trusty/amd64/gnome-calculator/filelist

Gil Shwartz (gil-shwartz) said : #4

Mark, thanks.

The thing is that this command is still being used (see my reference to the XF86Calculator key). Therefore I would expect the package to at least include a link from gcalctool to gnome-calculator.

Why not just change your keyboard shortcut for XF86Calculator from gcalctool to gnome-calculator, if it is not already set like that already?

I am using the Lxqt desktop environment. I checked my keyboard shortcuts and my XF86Calculator shortcut is already pointing to gnome-calculator. I did not even have to change any shortcut settings...

Maybe your shortcut is wrong because you have not installed gnome-calculator yet....

Gil Shwartz (gil-shwartz) said : #6

Of course I changed the keyboard shortcut, but the whole point is that things will just work. Anyway, thanks.