Using gaim to connect to gtalk

Asked by javaboy on 2007-05-19

I've got Ubuntu Edgy installed n im not able to use gaim or anyother messenger to connect to my gtalk account. I tried using Kopete, Psi and a few others too.. All of them give the error message that SSL plugin is not installed so cant connect. Connecting to gtalk accounts requires SSL it seems.. I searched the package manager, n it listed several packages with SSL in the name, some of them are installed also.. Now I need help finding out the name of the package i have to install to get gaim to work with gtalk accounts.

Thanks in advance.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu gaim Edit question
Assignee:
No assignee Edit question
Solved by:
Felix Heinonen
Solved:
2007-05-19
Last query:
2007-05-19
Last reply:
2007-05-19
Earth (matt-h) said : #1

Googletalk uses the Jabber protocol, so this is the account type you require. For your user name put your googletalk user name eg java.boy and then for the server either gmail.com or googlemail.com (depending on your google account)

Google themselves have instructions here (don't worry if it reads pidgin and not gaim, and substitutes XMPP for jabber) :
http://www.google.com/support/talk/bin/answer.py?answer=24073

javaboy (javaboy-ms) said : #2

Dear Matt,
I have read the procedure given in th google website.. and it woz working
perfectly fine for on Kubuntu, which i woz using till recently. Now i
removed that and installed ubuntu. It seems google talk accounts require
SSL/TLS enabled to connect. But it seems SSL plugin is not installed on my
Ubuntu.

Both Kopete and Psi gave the same error messages when I tried to connect..

Once I install that, It should work. From the Synaptic Package Manager, I
understand that a few packages with names similar to SSL are installed, but
there are too many packages with such names.How do I find the exact SSL
package?

Earth (matt-h) said : #3

Under modify account / advanced make sure you have the box "force SSL" *unchecked*. the connect server should be talk.google.com and the port 5222

javaboy (javaboy-ms) said : #4

I tried, but it is not connecting.

It says:

<email address hidden>/Gaim (Jabber) was disconnected due to an error:
SSL Handshake Failed. Gaim will not attempt to reconnect the account until
you correct the error and re-enable the account

Same message appears when the "Force old (5223) SSL" checkbox was checked
too..

Gaim says only that SSL handshake failed. The Psi messenger told me that It
cant connect using SSL either new or old, as the SSL plugin was not
installed..

Earth (matt-h) said : #5

have you tried specifying googlemail.com as the server instead of gmail.com

sorry, i'm running out of ideas

have you found this at all?
http://www.atlink.it/~conti/2007/02/20/adium-and-gaim-ssl-handshake-failed-gtalk/

javaboy (javaboy-ms) said : #6

Dear Matt,

I tried both gmail.com and googlemail.com, though I'm supposed to use
googlemail.com

And I tried the link too. It tell me to change the port number from 5222 to
80. Still I have the problem. I am currently using the chat window inside
gmail. That somehow works. If something comes up, please let me know. Thanks
for your time.. :)

javaboy (javaboy-ms) said : #8

Thanks Felix Heinonen, that solved my question.

TONYO (njorogean) said : #9

well

if you dont fancy the looooong process of installing PIDgin...

make sure your firewall or proxy can recognise the 5222 port...if not, add a rule (dependant on the one you have) if you dont, get someone or a system admin to do. If you are in a public zone "e.g. cyber, WI-FI ZONE etc." this wont matter.

Thereafter,
protocol: jabber
screen name: <your google name>
server: gmail.com <or googlemail.com> whichever works best in your case
password: <not necessary>

click advanced:

check "Use TLS if available"
check "Require TLS"

connect port: 5222

"DO NOT PUT ANYTHING ON THE CONNECTION SERVER"

Proxy type: <dependant on what you use> you can play around with this until you get the desired result

click "save"

connect, provide the password

Home "a bit wet" but your home!!!

r@ptor (piyush-singh-cse07) said : #10

how to connect to gtalk in ubuntu 8.04?
i have already installed gtalk on my system.First of all
on opening the gtalk.exe,there is popup but with no text wriiten.Though there is space fr entering the
username and password.But on entering username and password,and clicking on trying to sign in
it gives error.Please help..