how can I get sounds to work

Asked by stever on 2007-05-04

I can not get Gaim to play any sounds. I am using Xubuntu 7.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu gaim Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-04
Last reply:
2007-05-06
Jesus Gamio (jgamio) said : #1

Do you have the problem just with the gaim ?

stever (rileys2344) said : #2

yes. Other programs can play sound. I was trying to get to the Gaim site, but can not get ot the FAQ's. I saw another thread that pointed to the FAQ's.

Curtis Hovey (sinzui) said : #3

Gaim allows you to switch sound servers (for better or worse). The recent release Gaim from the past few months have new controls.

Choose the preferences menu, then the Sounds Tab.
GNOME desktop sounds (Ubuntu) use the ESD method.
Enable sounds Always
and adjust the the volume
You can test sound by selecting an event and choosing the test button.

Some apps will lock the ESD server. I experience this often with the Epiphany Web browser. You can check if an application is blocking sound by opening a terminal from Applications > Accessories and typing the command:
lsof | grep dsp
If and application/process is printed, then you may want to stop it.

stever (rileys2344) said : #4

I made the changes and tested. It still does not play sound. I also ran "lsof | grep dsp" no applications were listed.

Curtis Hovey (sinzui) said : #5

Hi steve, I'm sorry I didn't get back to you sooner.

Hmm. XFCE4 doesn't have a sound server, but commonly uses ESD. Maybe it is not running. Let's see if it is running, and if not, start it. Enter the following commands in the terminal:
ps ax | grep esd

If /usr/bin/esd is not listed then you can start it by entering the command:
esd &

I'm not familiar with Xubuntu's login sequence to advice how to start ESD automatically.

There are other option. Sound servers like ESD allow you to play multiple sounds at once. Sound mixers can do a fair job, though it might have problems when playing music and handling sound events. You can switch Gaim's sound server from ESD to a command. I think 'aplay' will be available to you. You can test both 'aplay' and the gaim sounds by entering the following command from the terminal:
aplay /usr/share/sounds/gaim/send.wav
If you hear something, then that is a viable option. If aplay reports it could not open the file, then we know that the gaim sounds are missing (meaning you may want to reinstall gaim, or select you own sounds). If you get the message command not found, then we know that the the alsa mixer is not being used--we need to substitute another wav playing commanfline tool.

Can you help with this problem?

Provide an answer of your own, or ask stever for more information if necessary.

To post a message you must log in.