FWUPD: Are these new error messages normal?

Asked by David Civera

Recently, fwupd is throwing two new (to me) error messages in /var/log/syslog

 fwupd[100718]: 22:11:50:0717 FuPluginTpm failed to load eventlog: Failed to open file "/sys/kernel/security/tpm0/binary_bios_measurements": No such file or directory


 fwupd[100718]: 22:11:50:0882 FuEngine failed to record HSI attributes: failed to get historical attr: json-glib version too old

The first one seems to have been solved on the GitHub (https://github.com/fwupd/fwupd/issues/4290) so not sure if I should just wait for an update.

The second is more puzzling as I seem to have the latest version of json-glib for Ubuntu 20.04 LTS.

Hope this helps.

Question information

English Edit question
Ubuntu fwupd Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

Which Ubuntu release and which version of fwupd are you running?

What is the output of the commands

uname -a
lsb_release -crid
apt policy fwupd libjson-glib-1.0-0

Do you see any negative effect besides the messages in the logs?

Revision history for this message
David Civera (dcivera) said (last edit ):

Thank you so much for your response. As of today, I haven't seen negative effects besides the error messages. Here's the info requested.

uname -a
Linux willowdale-matthew 5.4.0-104-generic #118-Ubuntu SMP Wed Mar 2 19:02:41 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux

lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 20.04.4 LTS
Release: 20.04
Codename: focal

apt policy fwupd libjson-glib-1.0-0
  Installed: 1.7.5-3~20.04.1
  Candidate: 1.7.5-3~20.04.1
  Version table:
 *** 1.7.5-3~20.04.1 500
        500 http://mirrors.linode.com/ubuntu focal-updates/main amd64 Packages
        100 /var/lib/dpkg/status
     1.3.9-4ubuntu0.1 500
        500 http://security.ubuntu.com/ubuntu focal-security/main amd64 Packages
     1.3.9-4 500
        500 http://mirrors.linode.com/ubuntu focal/main amd64 Packages
  Installed: 1.4.4-2ubuntu2
  Candidate: 1.4.4-2ubuntu2
  Version table:
 *** 1.4.4-2ubuntu2 500
        500 http://mirrors.linode.com/ubuntu focal/main amd64 Packages
        100 /var/lib/dpkg/status

Revision history for this message
Best Manfred Hampl (m-hampl) said :

fwupd version 1.7.5-3~20.04.1 was published only a week ago (after being in focal-proposed for two weeks).

- If there is no visible problem, then you probably better just leave it as it is.
- It could be worth trying to install a newer version of libjson-glib-1.0-0 and libjson-glib-1.0-common, either from a PPA or by manually downloading from the repositories for impish or jammy.
- And of course you are invited to create a bug report if you want

Revision history for this message
David Civera (dcivera) said :

Thank you so muhc Manfred. I'll leave it as is and create a bug report. I'm also curious to see if the issue goes away once I switch to 22.04 LTS.

Revision history for this message
David Civera (dcivera) said :

Thanks Manfred Hampl, that solved my question.