Ubuntu won't load on a Compaq CQ58 laptop

Asked by James Caird on 2013-05-16

I am having trouble loading Ubuntu on this new laptop. I've tried the 64bit versions of both 13.04 and 12.04. The problem seems to be that the EFI in the BIOS isn't finding the Ubuntu Grub file on the CD ROM. These have burned correctly as they will boot other machines, although not via EFI. I have tried the EFI Help Page but the range of options on this machine are more limited than suggested and only Secure Boot can be disabled. Legacy booting can be enabled but this is made unfunctional by the BIOS's prioritation of EFI which boots Windows 8 before reaching any Legacy alternative. I have forced the boot sequence (F9) and it finds the CD ROM but returns the message "No bootable device -- insert boot disk and press any key". The automated sequence tries the CD ROM 3 times before reverting to HDD boot. Any help would be gratefully received. Thanks. James

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fwts Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-05-18
Last query:
2013-05-18
Last reply:
2013-05-16
Best N1ck 7h0m4d4k15 (nicktux) said : #1

There is no need to revert back to legacy mode. If you revert back to legacy mode then is possible that Windows (that have been installed in EFI mode) will not boot at all.

BUT you must disable the secure boot option.

Then create a bootable USB of 64bit version of Ubuntu and boot from there. Bootable usb sticks work better (sometimes) than DVDs.

How to create an Ubuntu bootable usb-stick from within Windows, check the link below
http://www.ubuntu.com/download/desktop/create-a-usb-stick-on-windows

Regards
 NikTh

James Caird (james-caird) said : #2

Thanks NikTh, that solved my question.