No fsprotect for Ubuntu hirsute hippo?

Asked by Lucap

No fsprotect or aufs-dkms for Ubuntu hirsute hippo?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu fsprotect Edit question
Assignee:
No assignee Edit question
Solved by:
Lucap
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1
Revision history for this message
Manfred Hampl (m-hampl) said :
#2

For details see Bug #1922732

Revision history for this message
Lucap (lucap) said :
#3

Thanks actionparsnip and manfred.

This is highly annoying as i needed an immutable system.

https://bugs.launchpad.net/ubuntu/+source/fsprotect/+bug/1922732

>>Ubuntu kernels no longer provide AUFS support starting in hirsute, breaking the functionality provided by this package. Similar >>functionality is available from systemd (https://www.freedesktop.org/software/systemd/man/systemd-volatile-root.service.html) >>and from the overlayroot package from cloud-initramfs-tools, both of which use the in-kernel overlay filesystem instead of AUFS.

I can't find a easy step by step guide for using the systemd option for Ubuntu?

Revision history for this message
Manfred Hampl (m-hampl) said :
#4

Never tried anything like this myself.

A google search does not show much at all, there is definitely the need for instructions how to use this function.

Reading the man pages it seems that you have to add "systemd.volatile=yes" to the boot command line, and perhaps add some more parameters (like root=tmpfs, mount.usr=/dev/whatever etc.)

Revision history for this message
Lucap (lucap) said :
#5

I'll ask in the bug thread , thanks Manfred

Revision history for this message
Lucap (lucap) said :
#6

bilibop-lockfs can be used instead of Fsprotect as it uses overlayfs (if aufs is not available) and all you have to do is install it and add lockfs to ubuntu grub to activate it.

Revision history for this message
Lucap (lucap) said :
#7

Solved