The game fails to launch

Asked by stumpy

I ran it in terminal & this is what I got:

ceri@ceri-netbook:~$ frozen-bubble
        [[ Frozen-Bubble-2.2.0 ]]

  http://www.frozen-bubble.org/

  Copyright (c) 2000-2008 The Frozen-Bubble Team.

    Artwork: Alexis Younes
             Amaury Amblard-Ladurantie
    Soundtrack: Matthias Le Bidan
    Design & Programming: Guillaume Cottenceau
    Level Editor: Kim and David Joham
    Additional network programming: Mark Glines

  Originally sponsored by Mandriva <http://www.mandriva.com/>

  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License version 2, as
  published by the Free Software Foundation.

[SDL Init] Segmentation fault

I then manually selected open with perl in terminal to see if there is an error message & this is what I got:
        [[ Frozen-Bubble-2.2.0 ]]

  http://www.frozen-bubble.org/

  Copyright (c) 2000-2008 The Frozen-Bubble Team.

    Artwork: Alexis Younes
             Amaury Amblard-Ladurantie
    Soundtrack: Matthias Le Bidan
    Design & Programming: Guillaume Cottenceau
    Level Editor: Kim and David Joham
    Additional network programming: Mark Glines

  Originally sponsored by Mandriva <http://www.mandriva.com/>

  This program is free software; you can redistribute it and/or modify
  it under the terms of the GNU General Public License version 2, as
  published by the Free Software Foundation.

[SDL Init]

Warning: Program '/usr/bin/perl' crashed.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu frozen-bubble Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

Do you have 3D accelleration?

Revision history for this message
stumpy (stumpy-666-davies) said :
#2

Hi I don't know? how do I find out? I'm pretty new to linux so not sure how to check? as far as I'm aware I have an nvidia graphics card but not sure how to check this for sure either... please help if you know how I find this out I'll post the answer & any outcomes from the terminal if any are required, I follow instructions pretty well so there shouldn't be any issues if I'm told how I find this info, thanks

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

Can you give the output of:

sudo lshw -C display

Thanks

Revision history for this message
stumpy (stumpy-666-davies) said :
#4

ceri@ceri-netbook:~$ sudo lshw -C display
[sudo] password for ceri:
  *-display:0
       description: VGA compatible controller
       product: Mobile 945GME Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: msi pm bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:16 memory:fe980000-fe9fffff ioport:dc80(size=8) memory:d0000000-dfffffff(prefetchable) memory:fe940000-fe97ffff
  *-display:1 UNCLAIMED
       description: Display controller
       product: Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2.1
       bus info: pci@0000:00:02.1
       version: 03
       width: 32 bits
       clock: 33MHz
       capabilities: pm bus_master cap_list
       configuration: latency=0
       resources: memory:fe880000-fe8fffff

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#5

Looks like its using the right driver, The intel chip you have should have enough grunt to run the game. I suggest you log a bug with frozen-bubble

This may already be a bug but if this is the case yours will be marked as a duplicate and you can watch the main one to see if a fix is suggested or committed to the program itself. The output you initially gave is a great starting point (just as it is here).

Other than that I am not sure, others may be able to contribute though, lets see.

Revision history for this message
stumpy (stumpy-666-davies) said :
#6

it seems that you're using an incompatible (too recent) version of perl-SDL on FB1. Either downgrade or apply this patch: http://www.frozen-bubble.org/perl-SDL.patch

I downloaded this patch but don't understand how to apply it, when I click it, it just opens in Kate (text editor) what do I do with the patch?

thanks!

Revision history for this message
vgfdsjtgm ujhytduy (william785) said :
#7

Yes its exactly the same issue that I faced some days ago but you can see some detailed guidance about it on https://cricfacts.com/ this will help you to solve it quickly.

Revision history for this message
stumpy (stumpy-666-davies) said (last edit ):
#8

@ vgfdsjtgm ujhytduy (william785) - Thanks, but my problem was over 11 years ago,

and your reply gives a link to a website with facts about cricket, and has nothing what so ever to do with frozen-bubble

I believe your a hacker, maybe a mod needs to check on this

I've long since left linux

Revision history for this message
gvfdshr gvrdr (janecy834) said :
#9

Exactly the same issue that I am facing in my device the software looks like its running normally but the game is not launching as you can see here https://bradfordremovalservice.com/

Can you help with this problem?

Provide an answer of your own, or ask stumpy for more information if necessary.

To post a message you must log in.