freerdp 1.0.1 in 12.04, smard card mapping not working

Asked by wally

Hi guys, I recently change my OS from 9.04 to 12.04, and when I use freerdp with smard card mapping to login my windows server 2008 and found it that smart card reader not detected, I also login to windows server 2003, it`s not working, too. but I can use this when I was in 9.04, is this function been drop or what?

p.s: I know the package 'libfreerdp-plugins-standard' not contain, so I rebuild the package with -DWITH_PSCS=ON, and make sure this .so file installed on my computer, but the function still not working.

Question information

English Edit question
Ubuntu freerdp Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :

Are there any bugs reported?
How did you get to 12.04 from 9.04?

Revision history for this message
wally (wally-yeh) said :

I just reinstall entire OS in my computer.
but when I was in 9.04, I can use freerdp and smart card mapping.
after I get into 12.04, I apt-get freerdp and can not use smart card mapping anymore.

I know freerdp had change a lot since 1.0.0, but I `m not sure is this function been drop or just broken.

Revision history for this message
wally (wally-yeh) said :

Oops, my old version rdp use --plugin rdpdr --data scard --, and new version is --plugin rdpdr --data scard:scard --, after typing the missing ":scard", It can works on my Windows server 2008. but still not working on my Win7, and I believe this is a Windows settings issue.

and I wonder is there a hole command table about the new version rdp? I still search this table on freerdp website.