freeradius-mysql not available

Asked by Marikawn

I'm trying to setup my brand new instance of Ubuntu 18.04.1 LTS Server with mysql and freeradius. One of the required packages is "freeradius-mysql". When I run the following command I get an error:

apt-get install freeradius-mysql

Package freeradius-mysql is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

Am I missing something? This used to work on previous versions of Ubuntu Server.


Question information

English Edit question
Ubuntu freeradius Edit question
No assignee Edit question
Solved by:
Manfred Hampl
Last query:
Last reply:
Revision history for this message
Manfred Hampl (m-hampl) said :

For diagnostic purposes, what is the output of the commands

uname -a
lsb_release -crid
sudo apt-get udpate
apt-cache policy freeradius freeradius-mysql

Revision history for this message
Marikawn (marikawn) said :

# uname -a
Linux ubuntu 4.15.0-30-generic #32-Ubuntu SMP Thu Jul 26 17:42:43 UTC 2018 x86_64 x86_64 x86_64 GNU/Linux

Please see below:

# lsb_release -crid
Distributor ID: Ubuntu
Description: Ubuntu 18.04.1 LTS
Release: 18.04
Codename: bionic

# apt-get update
Hit:1 bionic InRelease
Hit:2 bionic-security InRelease
Hit:3 bionic-updates InRelease
Reading package lists... Done

# apt-cache policy freeradius freeradius-mysql
  Installed: 3.0.16+dfsg-1ubuntu3
  Candidate: 3.0.16+dfsg-1ubuntu3
  Version table:
 *** 3.0.16+dfsg-1ubuntu3 500
        500 bionic/main amd64 Packages
        100 /var/lib/dpkg/status
  Installed: (none)
  Candidate: (none)
  Version table:

Revision history for this message
Best Manfred Hampl (m-hampl) said :

freeradius-mysql is in the "universe" repository, which you seem not to have enabled.

Revision history for this message
Marikawn (marikawn) said :

Thank you very much!

Revision history for this message
Marikawn (marikawn) said :

Thanks Manfred Hampl, that solved my question.