Can Any one help in using fragroute?

Asked by M P Sairam


I'm having an issue with fragroute. When i started fragroute with ip-fragment size as 64. I'm unable to ping to the remote machine, response is not coming because ARP is not getting resolved for sending response on the remote machine. ARP is not getting resolved when i ping from remote machine. Please help me out if any one has solution or an alternative?


Question information

English Edit question
Ubuntu fragroute Edit question
No assignee Edit question
Solved by:
M P Sairam
Last query:
Last reply:
Revision history for this message
Bhavani Shankar (bhavi) said :
Revision history for this message
M P Sairam (sairam-mp) said :

I think they modified the fragroute code becoz when i tried diff with original tar files downloaded from fragroute site and from ubuntu packages sites, there were many changes which actually broke the fragroute functionality. I Don't know whether they tested it or not but i tried on 3 different machines and i was getting the same error with different rule sets. if ping itself is having the problem what about other TCP/UDP traffic. i tried HTTP and FTP traffic i got the same issue.

Revision history for this message
Bhavani Shankar (bhavi) said :

Download the original tarball and then compile and try

Revision history for this message
M P Sairam (sairam-mp) said :

I tried that one also, but no luck the image is working fine with Fedora 8. I observed a behavior, when i started fragroute on my FC8 machine and did a ping from my Ubuntu ibex machine still ping itself is not working and i checked with packet capture. The reponse packets are reaching the interface of my ubuntu machine, but still ping says 100% packet loss. I think kernel is not giving the packets to the application. Is there any flag to be set in proc ?

Revision history for this message
M P Sairam (sairam-mp) said :

I downloaded the source code for fragroute from ubuntu packages, i saw a README under debian folder in which it was stated that for fragroute to work under Ubuntu Intrepid we need disable spoofprotect flag.

For disabling spoofprotect variable please run this command:

echo "0" > /proc/sys/net/ipv4/conf/all/rp_filter

Fragroute worked after doing this change.

Please read the README file from the source code under debian folder for more info.

source can be found at