Latest version of flash not working in Ubuntu 12.04

Asked by Walker Allen on 2013-07-11

I installed Ubuntu 12.04 on 7/09/13 on a machine that used to run Windows XP. In Firefox, noted flash not working. No message stating any problem, just video didn't work. I searched Launchpad and followed a suggestion to find out what Flash software I had. I discovered I did not have Ubuntu Restricted Extras, so I downloaded and installed same. I went to Software Center and uninstalled Flash, then reinstalled it, thinking it might install the latest version (flashplugin-installer 11.2.202.297ubuntu0.12.04.1). Still didn't work. I uninstalled Flash again and then opened Firefox and videos worked-sort of. Very jerky motion and a message opens stating that I need to upgrade to the latest version of Flash. So, unsure how to fix this. Suggestions?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Last query:
2013-07-12
Last reply:
2013-07-13
michael (yellupcm-gmail) said : #1

Read this site.

http://www.omgubuntu.co.uk/2012/02/adobe-adandons-flash-on-linux

Chrome does not need Adobe Flash. Might give it a try. Minitube (in Ubuntu Software Center) will play YouTube files.
The 11.2 series should work, but 11.3 and higher will not work.

What is the output of :

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

Walker Allen (mwajr) said : #3

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch:cxx-3.0-ia32:cxx-3.0-noarch:cxx-3.1-ia32:cxx-3.1-noarch:cxx-3.2-ia32:cxx-3.2-noarch:cxx-4.0-ia32:cxx-4.0-noarch:desktop-3.1-ia32:desktop-3.1-noarch:desktop-3.2-ia32:desktop-3.2-noarch:desktop-4.0-ia32:desktop-4.0-noarch:graphics-2.0-ia32:graphics-2.0-noarch:graphics-3.0-ia32:graphics-3.0-noarch:graphics-3.1-ia32:graphics-3.1-noarch:graphics-3.2-ia32:graphics-3.2-noarch:graphics-4.0-ia32:graphics-4.0-noarch:printing-3.2-ia32:printing-3.2-noarch:printing-4.0-ia32:printing-4.0-noarch:qt4-3.1-ia32:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04.2 LTS
Release: 12.04
Codename: precise
Linux GA-7VAXP 3.5.0-36-generic #57~precise1-Ubuntu SMP Thu Jun 20 15:22:35 UTC 2013 i686 athlon i386 GNU/Linux
ii browser-plugin-gnash 0.8.10-5ubuntu1 GNU Shockwave Flash (SWF) player - Plugin for Mozilla and derivatives
ii browser-plugin-lightspark 0.5.5-0ubuntu1 High-performance SWF player - Mozilla Plugin (experimental)
ii flashplugin-installer 11.2.202.297ubuntu0.12.04.1 Adobe Flash Player plugin installer
ii gnash 0.8.10-5ubuntu1 GNU Shockwave Flash (SWF) player
ii gnash-common 0.8.10-5ubuntu1 GNU Shockwave Flash (SWF) player - Common files/libraries
ii lightspark-common 0.5.5-0ubuntu1 High-performance SWF player - common data
null@GA-7VAXP:~$

Walker Allen (mwajr) said : #4

Sorry, meant to thank you for the reponse(s). Haven't tried Chrome yet...guess I just wanted Firefox to work since I'm used to that browser.

sudo apt-get --purge remove browser-plugin-gnash browser-plugin-lightspark

sudo apt-get --purge remove flashplugin-installer gnash gnash-common lightspark-common

sudo apt-get --purge autoremove

sudo apt-get clean

Enable the partner repo then install adobe-flashplugin. Close all browsers and then rerun. Web browsers are pretty similar. Back button, refresh....all the same so I don't get how you can be 'used to' a browser.....

Walker Allen (mwajr) said : #6

Hi, sorry for the delayed response, other live stuff to deal with... ok, I followed the 1st 4 steps outlined above. Got stuck on enabling the partner repositories. I found some instructions on doing this via the command line; see below:
Command Line Way:
    Open the sources.list file: gksudo gedit /etc/apt/sources.list
    Add the partner repositories by removing the # in front of the following lines (maverick is the version of your Ubuntu installation, it may differ)

    # deb http://archive.canonical.com/ubuntu maverick partner
    # deb-src http://archive.canonical.com/ubuntu maverick partner

alt text

    Save and Close.

    Resynchronize the package index files from their sources: sudo apt-get update

I did this, got no errors, installed the flash plugin with browser closed but still no working flash player. I'm doing something wrong, just not sure what.
Thanks so much for trying to help me out, I appreciate your time.
BTW, for me, "getting used to a browser' is just a cosmetic thing...

Can you help with this problem?

Provide an answer of your own, or ask Walker Allen for more information if necessary.

To post a message you must log in.