I'm having trouble with Flash in Ubuntu 12.04 LTS

Asked by John Hill on 2012-12-17

I've been trying to figure out why flash is not working in Ubuntu 12.04, which I just installed on my computer. I try to watch online videos, and it gives me a shockwave flash error. I tried all kinds of things, including the ubuntu-restricted-extras, and install-flashplugin, and nothing worked. I finally went in and uninstalled Adobe Flash Player, and it worked in a lot of cases, but not all of them. I think it only works on Youtube videos that don't have ads, because the ads require flash but YouTube doesn't with their HTML5 experiment.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Solved by:
N1ck 7h0m4d4k15
Solved:
2013-01-10
Last query:
2013-01-10
Last reply:
2013-01-10

This question was reopened

John Hill (jhilp) said : #1

I'm just getting kind of frustrated with the whole thing. I'm very excited about Ubuntu, but since I use the computer mostly for internet browsing and watching online videos, I just can't use it as much without flash working. I've been using both Google Chrome and Firefox browsers.

N1ck 7h0m4d4k15 (nicktux) said : #2

Hi ,

please open a terminal (CTRL+ALT+T) and give here the results of below commands

$ dpkg -l | grep -ie flash -ie gnash

$ apt-cache policy ubuntu-restricted-extras

$ lsb_release -rcd ; uname -r

$ lscpu

Thanks

John Hill (jhilp) said : #3

Sorry I took so long getting back to you. Here's what comes back. Thanks!

john-hill@johnhill-desktop:~$ dpkg -l | grep -ie flash -ie gnash
john-hill@johnhill-desktop:~$ apt-cache policy ubuntu-restricted-extras
ubuntu-restricted-extras:
  Installed: 57
  Candidate: 57
  Version table:
 *** 57 0
        500 http://us.archive.ubuntu.com/ubuntu/ precise/multiverse i386 Packages
        100 /var/lib/dpkg/status
john-hill@johnhill-desktop:~$ lsb_release -rcd ; uname -r
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
3.2.0-34-generic-pae
john-hill@johnhill-desktop:~$ lscpu
Architecture: i686
CPU op-mode(s): 32-bit
Byte Order: Little Endian
CPU(s): 1
On-line CPU(s) list: 0
Thread(s) per core: 1
Core(s) per socket: 1
Socket(s): 1
Vendor ID: AuthenticAMD
CPU family: 6
Model: 10
Stepping: 0
CPU MHz: 1726.366
BogoMIPS: 3452.73
L1d cache: 64K
L1i cache: 64K
L2 cache: 512K
john-hill@johnhill-desktop:~$

N1ck 7h0m4d4k15 (nicktux) said : #4

Ubuntu-restricted-extras are installed , but where is flash ?

The command $ sudo dpkg -l | grep -ie flash -ie gnash , should return something.

Lets try to install it again .

$ sudo apt-get install flashplugin-downloader

Give any results back here.

Thanks

John Hill (jhilp) said : #5

I installed that, and now most YouTube videos work. But now whenever I access a website that requires flash or a video with an ad, it says "could not load Shockwave flash". Any idea how to fix that?

N1ck 7h0m4d4k15 (nicktux) said : #6

Maybe the problem is related to the version of flash player .

I have 2 older versions of flash player in my cloud (Ubuntu One). We will test the first older version fist. (11.01).

Download the compressed file from here : http://ubuntuone.com/0maDagKUuWihfc8A2ktnlp

is the 32bit version (for your OS) .

Right click and "Extract here" , then open the folder and take the file "libflashplayer.so" and copy it to this path

/usr/lib/mozilla/plugins/libflashplayer.so (the mozilla firefox must be closed and you will need root privileges). You can open nautilus as root with the command below

$ gksudo nautilus

Am I understandable ?

The only thing you have to do , is to replace the file libflashplayer.so , with the one I give you.

Tell me if works.

Thanks

John Hill (jhilp) said : #7

If you start getting frustrated and want to give up on me, I'll understand. Maybe I'm just too inexperienced, but somehow this file extracting and downloading stuff keeps giving me fits. Here's what happens: I click on the link you provided and it downloads the file. Then the Archive Manager comes up, and it shows 2 folders; one called "usr" with 892.2 kb and another called "libflashplayer.so" with 16.3 mb. If I right-click, it just gives me the option to extract, not "extract here" as you mentioned. I also don't see where to copy it to the patch you provided. Sorry to be such a hard case, I'm liking this Ubuntu system a lot, but getting kind of frustrated. By the way, hope this doesn't make your job harder, but I uninstalled 12.04 and installed 10.04 instead. I was thinking maybe since I've got an older computer that the older version might work better. Thanks so much for your help!

N1ck 7h0m4d4k15 (nicktux) said : #8

Ubuntu 12.04 and Ubuntu 10.04 using almost the same packages. Both are LTS versions . But Ubuntu 10.04 will be EOL in a few months (End Of Life) and you have to upgrade again.

Ubuntu 12.04 is not heavy .. you can use an integrated environment called ubuntu-2d (is lightweight). You only have to choose this environment from the login screen. See the pictures below.

http://i.stack.imgur.com/34AbA.png
http://i.stack.imgur.com/gPLtQ.png

Now , about the problem .. I assume you downloaded the file in "Downloads" folder (save the file there)
Just open a terminal and copy - paste from here the commands below (one at time)

$ cd Downloads
$ tar xvzf flashplayer11_1r102_63_linux.i386.tar.gz
$ sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

Any error message , please post back here.
Then open a again Firefox and see if works better.

Thank you.

John Hill (jhilp) said : #9

Thanks NikTh, that solved my question.

John Hill (jhilp) said : #10

That did it! Thanks so much for the help! You're the best!

N1ck 7h0m4d4k15 (nicktux) said : #11

Glad we solved it.

Now do something extra , because we don't want Ubuntu to upgrade flash player to the newer version. We want to keep the older version that works.

Open a terminal and give this command

$ echo 'flashplugin-installer hold' | sudo dpkg --set-selections

Now when you give

$ dpkg --get-selections | grep -i flash

the correct result should be

$ flashplugin-installer hold

Thanks.

N1ck 7h0m4d4k15 (nicktux) said : #12

If for some reason you want to undo the above process (with the hold) , you can do

$ echo 'flashplugin-installer install' | sudo dpkg --set-selections

and you will see

$ dpkg --get-selections | grep -i flash

the result

$ flashplugin-installer install

That means that flashplugin updates will be applied (if any)

Thanks

John Hill (jhilp) said : #13

Nick, I'm working on another computer now that's similar to last one that we fixed, and it has this same problem. I tried these same commands in this computer, but they didn't work.

Here are the responses:

john-hill@john-hill-desktop:~$ cd Downloads
john-hill@john-hill-desktop:~/Downloads$ tar xvzf flashplayer11_1r102_63_linux.i386.tar.gz
tar (child): flashplayer11_1r102_63_linux.i386.tar.gz: Cannot open: No such file or directory
tar (child): Error is not recoverable: exiting now
tar: Child returned status 2
tar: Error is not recoverable: exiting now
john-hill@john-hill-desktop:~/Downloads$ sudo cp libflashplayer.so /usr/lib/mozilla/plugins/
[sudo] password for john-hill:
cp: cannot stat `libflashplayer.so': No such file or directory

Please let me know what you think. Thanks!

N1ck 7h0m4d4k15 (nicktux) said : #14

This is a problem with tar command or permissions

see the permissions of the file .. and change them accordingly

ls -ld flashplayer11_1r102_63_linux.i386.tar.gz

or maybe the file IS NOT on Downloads folder.. see where the file saved (?)

Thanks

John Hill (jhilp) said : #15

Ok, so I tried running that command by itself in the terminal (is that what I was supposed to do?), and here's what came back.

john-hill@john-hill-desktop:~$ ls -ld flashplayer11_1r102_63_linux.i386.tar.gz
ls: cannot access flashplayer11_1r102_63_linux.i386.tar.gz: No such file or directory
john-hill@john-hill-desktop:~$

Let me know if that wasn't what you wanted me to do. Thanks!

Best N1ck 7h0m4d4k15 (nicktux) said : #16

The results of the command shows that the file is not there. "No such file or directory" .

Try below commands , please copy-paste from here one by one.

wget "http://ubuntuone.com/0maDagKUuWihfc8A2ktnlp" -O ~/flashplugin.tar.gz
tar xvzf flashplugin.tar.gz
sudo cp libflashplayer.so /usr/lib/mozilla/plugins/

Re - Open mozilla Firefox and see if works.

If yes , then follow the commands in answer #11 to Hold the package.

Thanks

John Hill (jhilp) said : #17

Thanks NikTh, that solved my question.

John Hill (jhilp) said : #18

That did it!! Thanks! You're the best!

Nigel (nigelturl) said : #19

For anyone checking this thread and not having succes, check out the thread at http://ubuntuforums.org/showthread.php?t=2179125. It gives a solution for those of us dinosaurs with Socket A CPUs.