Can't Install Adobe Flash on Kubuntu

Asked by Rob Smithson on 2012-10-22

I'm running Kubuntu 12.04 on a Mac G4 Powerbook. I took the right download from the Adobe website and opened the instructions. I've opened a Terminal but on reading the instructions I'm simply confused. I'm guessing this is a relitively simple task but I've never used a Terminal to do anything before and never used Linux.

A few examples of my confusion...

Unpack the plugin tar.gz and copy the files to the appropriate location. - What is the appropriate location ?
Save the plugin tar.gz locally and note the location the file was saved to. - If they are copied to the appropriate location already, why do I need to save them locally?
Launch terminal and change directories to the location the file was saved to. - How do I change directories in the Terminal?
Identify the location of the browser plugins directory, based on your Linux distribution and Firefox version - Being new to Linux and as such Dolphin I'm struggling with this
Copy libflashplayer.so to the appropriate browser plugins directory. At the prompt type: + cp libflashlayer.so <BrowserPluginsLocation> - This bit I actually get. Hurah!!
Copy the Flash Player Local Settings configurations files to the /usr directory. At the prompt type: + sudo cp -r usr/* /usr - This bit I don't get at all....

Could someone please take the time to help by explaining step-by-step what to do and how to do it. I tried posting on the Kubuntu community forum for new guys but no one has helped. It's frustrating because I can see this is a very simple task if you know what you're doing. Sadly I don't....

Thanks, Rob :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2012-10-22
Last query:
2012-10-22
Last reply:
2012-10-22

Adobe don't support PPC so the file from the Adobe site is of no value to you. They only support x86 and X86_64. Can you please give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|spark'

Thanks

Rob Smithson (robinhoodless) said : #2

Hi,

Thanks for the info re Adobe.

output reads:
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
Linux Zilla 3.2.0-32-powerpc-smp #51-Ubuntu SMP Wed Sep 26 21:34:37 UTC 2012 ppc
 ppc ppc GNU/Linux
ii gnash 0.8.10-5ubuntul
 GNU Shockwave Flash (SWF) player
ii gnash-common 0.8.10-5ubuntul
 GNU Shockwave Flash (SWF) player - Common files/libraries
rob@Zilla:~$

Thanks

sudo apt-get --purge remove gnash gnash-common
sudo apt-get clean
sudo apt-get install browser-plugin-lightspark

Should give you flash

Rob Smithson (robinhoodless) said : #4

It kind of worked. Playback is very jumpy though and freezes a few seconds at a time. I have high speed broadband, so that shouldn't be causing it. There's also no sound, but that's happening in VLC with movies I tried playing. Was going to post seperately about that.

Thanks very much :)

Rob Smithson (robinhoodless) said : #5

I did try installing the Flash-Aid plugin from the Firefox plugins. Would this conflict with Lightspark?

Rob Smithson (robinhoodless) said : #6

I removed Flash-Aid and restarted Firefox but it's still not working properly

Rob Smithson (robinhoodless) said : #7

Works absolutely fine in rekong....

Rob Smithson (robinhoodless) said : #8

Thanks actionparsnip, that solved my question.