Flash 11 plug-in for Firefox 7 stalls

Asked by Phil-ganchev on 2011-11-08

When I load a Web page that has an embedded flash video in Firefox (such as on Youtube), it stalls. It loads the first 1 or 2 seconds and starts playing in the browser, but then the video stalls, because it goes back to the current point in the video and downloads again from there, and it keeps doing that. This is evident from the gray line in the progress indicator bar: the gray line first grows longer than the white line which shows what we have already watched in the video; but after 1 or 2 seconds, it shortens again to the end of the white line, and soon after that the video stops playing.

Clicking on the pause/play button does not do anything. Clicking to another time point in the video does not do anything.

This started happening right after I upgraded from Ubuntu 10.10 to 11.10 yesterday. I'm using the default setup. It has Firefox 7.0.1. Packages flashplugin-downloader and flashplugin-installer are installed, both version 11.0.1.152ubuntu1. I have some browser add-ons, but all of them are disabled.

When I download the flash file and watch it with Mplayer, it works fine.

(From the other browsers, Epiphany does not have a flash plug-in, and Chromium does not start.)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Solved by:
Phil-ganchev
Solved:
2011-11-09
Last query:
2011-11-09
Last reply:
2011-11-09
Sam_ (and-sam) said : #1

> flashplugin-downloader and flashplugin-installer

Please remove either one of the versions and restart firefox.

Phil-ganchev (phil-ganchev) said : #2

flashplugin-downloader depends on flashplugin-installer, so if I remove the former, I have to remove the latter, and this leaves me without any flash player plug-in. Removing only flashplugin-installer and restarting Firefox does not change the symptoms.

Phil-ganchev (phil-ganchev) said : #3

Sorry, I meant to say the installer depends on the downloader, so if I remove the downloader, I also remove the installer.

Indeed, flashplugin-installer and flashplugin-downloader provide Flash together. Removing one without the other, even if you could, would not be likely to do any good.

Please open a Terminal window (Ctrl+Alt+T) and run this command by copying it to the clipboard, pasting it into the Terminal, and pressing enter:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|lightspark'

Then select all the text in the Terminal (Edit > Select All), copy it to the clipboard (Edit > Copy), and paste it here.

Phil-ganchev (phil-ganchev) said : #5

Thanks Eliah! That solved the problem. It was caused by a flashblock extension which is apparently incompatible with this version of Firefox or this version of Adobe flash but was not automatically uninstalled and was not showing up in the add-ons manager.

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf|lightspark'
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux levsky 3.0.0-12-generic #20-Ubuntu SMP Fri Oct 7 14:50:42 UTC 2011 i686 i686 i386 GNU/Linux
ii flashplugin-downloader 11.0.1.152ubuntu1 Adobe Flash Player plugin downloader
rc xul-ext-flashblock 1.5.13-1build1 mozilla extension to block Adobe Flash content

After purging xul-ext-flashblock, flash now works fine:

sudo apt-get --purge remove xul-ext-flashblock
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be REMOVED:
  xul-ext-flashblock*
0 upgraded, 0 newly installed, 1 to remove and 21 not upgraded.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]?
(Reading database ... 283747 files and directories currently installed.)
Removing xul-ext-flashblock ...
Purging configuration files for xul-ext-flashblock ...

I'm glad to hear the problem is fixed.