Ubuntu 11.04 64 bits: cannot install flashplugin

Asked by wierdlmate@gmail.com on 2011-09-30

When I start chromium or firefox, it reports "flashplugin is blocked it is out of date". But I was not successful in installing flashplugin. Here is what I get

$ sudo apt-get install flashplugin-nonfree
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following extra packages will be installed:
  flashplugin-installer nspluginwrapper
Suggested packages:
  xulrunner-1.9 ttf-xfree86-nonfree xfs
The following NEW packages will be installed:
  flashplugin-installer flashplugin-nonfree nspluginwrapper
0 upgraded, 3 newly installed, 0 to remove and 17 not upgraded.
Need to get 0 B/186 kB of archives.
After this operation, 811 kB of additional disk space will be used.
Do you want to continue [Y/n]? y
Preconfiguring packages ...
Selecting previously deselected package nspluginwrapper.
(Reading database ... 442004 files and directories currently installed.)
Unpacking nspluginwrapper (from .../nspluginwrapper_1.2.2-0ubuntu9_amd64.deb) ...
Selecting previously deselected package flashplugin-installer.
Unpacking flashplugin-installer (from .../flashplugin-installer_10.3.183.10ubuntu0.11.04.1_amd64.deb) ...
Selecting previously deselected package flashplugin-nonfree.
Unpacking flashplugin-nonfree (from .../flashplugin-nonfree_10.3.183.10ubuntu0.11.04.1_amd64.deb) ...
Processing triggers for man-db ...
Setting up nspluginwrapper (1.2.2-0ubuntu9) ...
plugin dirs: :/var/lib/flashplugin-installer/
Auto-update plugins from /usr/lib/mozilla/plugins
Looking for plugins in /usr/lib/mozilla/plugins
*** glibc detected *** nspluginwrapper: double free or corruption (out): 0x0000000001692430 ***
======= Backtrace: =========
/lib/x86_64-linux-gnu/libc.so.6(+0x78a8f)[0x7f0f71b6fa8f]
/lib/x86_64-linux-gnu/libc.so.6(cfree+0x73)[0x7f0f71b738e3]
/lib/x86_64-linux-gnu/libdl.so.2(+0x1565)[0x7f0f71e8c565]
/lib/x86_64-linux-gnu/libdl.so.2(dlsym+0x4a)[0x7f0f71e8c09a]
nspluginwrapper[0x4017e1]
nspluginwrapper[0x401902]
nspluginwrapper[0x401661]
nspluginwrapper[0x402f12]
nspluginwrapper[0x403b6f]
/lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xff)[0x7f0f71b15eff]
nspluginwrapper[0x401259]
======= Memory map: ========
00400000-00406000 r-xp 00000000 08:07 24478222 /usr/lib/nspluginwrapper/x86_64/linux/npconfig
00605000-00606000 r--p 00005000 08:07 24478222 /usr/lib/nspluginwrapper/x86_64/linux/npconfig
00606000-00607000 rw-p 00006000 08:07 24478222 /usr/lib/nspluginwrapper/x86_64/linux/npconfig
00607000-00608000 rw-p 00000000 00:00 0
01679000-0169a000 rw-p 00000000 00:00 0 [heap]
7f0f68000000-7f0f68021000 rw-p 00000000 00:00 0
7f0f68021000-7f0f6c000000 ---p 00000000 00:00 0
7f0f6e8ed000-7f0f6e902000 r-xp 00000000 08:07 22831242 /lib/x86_64-linux-gnu/libgcc_s.so.1
7f0f6e902000-7f0f6eb01000 ---p 00015000 08:07 22831242 /lib/x86_64-linux-gnu/libgcc_s.so.1
7f0f6eb01000-7f0f6eb02000 r--p 00014000 08:07 22831242 /lib/x86_64-linux-gnu/libgcc_s.so.1
7f0f6eb02000-7f0f6eb03000 rw-p 00015000 08:07 22831242 /lib/x86_64-linux-gnu/libgcc_s.so.1
7f0f6eb03000-7f0f6ebeb000 r-xp 00000000 08:07 24675952 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.14
7f0f6ebeb000-7f0f6edea000 ---p 000e8000 08:07 24675952 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.14
7f0f6edea000-7f0f6edf2000 r--p 000e7000 08:07 24675952 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.14
7f0f6edf2000-7f0f6edf4000 rw-p 000ef000 08:07 24675952 /usr/lib/x86_64-linux-gnu/libstdc++.so.6.0.14
7f0f6edf4000-7f0f6ee09000 rw-p 00000000 00:00 0
7f0f7011e000-7f0f7014f000 r-xp 00000000 08:07 23044102 /opt/google/talkplugin/libnpgoogletalk64.so
7f0f7014f000-7f0f7034e000 ---p 00031000 08:07 23044102 /opt/google/talkplugin/libnpgoogletalk64.so
7f0f7034e000-7f0f70350000 r--p 00030000 08:07 23044102 /opt/google/talkplugin/libnpgoogletalk64.so
7f0f70350000-7f0f70351000 rw-p 00032000 08:07 23044102 /opt/google/talkplugin/libnpgoogletalk64.so
7f0f70351000-7f0f7035d000 r-xp 00000000 08:07 22831208 /lib/x86_64-linux-gnu/libnss_files-2.13.so
7f0f7035d000-7f0f7055c000 ---p 0000c000 08:07 22831208 /lib/x86_64-linux-gnu/libnss_files-2.13.so
7f0f7055c000-7f0f7055d000 r--p 0000b000 08:07 22831208 /lib/x86_64-linux-gnu/libnss_files-2.13.so
7f0f7055d000-7f0f7055e000 rw-p 0000c000 08:07 22831208 /lib/x86_64-linux-gnu/libnss_files-2.13.so
7f0f7055e000-7f0f70569000 r-xp 00000000 08:07 22831211 /lib/x86_64-linux-gnu/libnss_nis-2.13.so
7f0f70569000-7f0f70768000 ---p 0000b000 08:07 22831211 /lib/x86_64-linux-gnu/libnss_nis-2.13.so
7f0f70768000-7f0f70769000 r--p 0000a000 08:07 22831211 /lib/x86_64-linux-gnu/libnss_nis-2.13.so
7f0f70769000-7f0f7076a000 rw-p 0000b000 08:07 22831211 /lib/x86_64-linux-gnu/libnss_nis-2.13.so
7f0f7076a000-7f0f70781000 r-xp 00000000 08:07 22831196 /lib/x86_64-linux-gnu/libnsl-2.13.so
7f0f70781000-7f0f70980000 ---p 00017000 08:07 22831196 /lib/x86_64-linux-gnu/libnsl-2.13.so
7f0f70980000-7f0f70981000 r--p 00016000 08:07 22831196 /lib/x86_64-linux-gnu/libnsl-2.13.so
7f0f70981000-7f0f70982000 rw-p 00017000 08:07 22831196 /lib/x86_64-linux-gnu/libnsl-2.13.so
7f0f70982000-7f0f70984000 rw-p 00000000 00:00 0
7f0f70984000-7f0f7098c000 r-xp 00000000 08:07 22831198 /lib/x86_64-linux-gnu/libnss_compat-2.13.so
7f0f7098c000-7f0f70b8b000 ---p 00008000 08:07 22831198 /lib/x86_64-linux-gnu/libnss_compat-2.13.so
7f0f70b8b000-7f0f70b8c000 r--p 00007000 08:07 22831198 /lib/x86_64-linux-gnu/libnss_compat-2.13.so
7f0f70b8c000-7f0f70b8d000 rw-p 00008000 08:07 22831198 /lib/x86_64-linux-gnu/libnss_compat-2.13.so
7f0f70b8d000-7f0f70c11000 r-xp 00000000 08:07 22831182 /lib/x86_64-linux-gnu/libm-2.13.so
7f0f70c11000-7f0f70e10000 ---p 00084000 08:07 22831182 /lib/x86_64-linux-gnu/libm-2.13.so
7f0f70e10000-7f0f70e11000 r--p 00083000 08:07 22831182 /lib/x86_64-linux-gnu/libm-2.13.so
7f0f70e11000-7f0f70e12000 rw-p 00084000 08:07 22831182 /lib/x86_64-linux-gnu/libm-2.13.so
7f0f70e12000-7f0f70e2f000 r-xp 00000000 08:07 24063005 /usr/lib/libv4lconvert.so.0
7f0f70e2f000-7f0f7102e000 ---p 0001d000 08:07 24063005 /usr/lib/libv4lconvert.so.0
7f0f7102e000-7f0f71033000 r--p 0001c000 08:07 24063005 /usr/lib/libv4lconvert.so.0
7f0f71033000-7f0f71034000 rw-p 00021000 08:07 24063005 /usr/lib/libv4lconvert.so.0
7f0f71034000-7f0f71084000 rw-p 00000000 00:00 0
7f0f71084000-7f0f7109c000 r-xp 00000000 08:07 22831233 /lib/x86_64-linux-gnu/libpthread-2.13.so
7f0f7109c000-7f0f7129c000 ---p 00018000 08:07 22831233 /lib/x86_64-linux-gnu/libpthread-2.13.so
7f0f7129c000-7f0f7129d000 r--p 00018000 08:07 22831233 /lib/x86_64-linux-gnu/libpthread-2.13.so
7f0f7129d000-7f0f7129e000 rw-p 00019000 08:07 22831233 /lib/x86_64-linux-gnu/libpthread-2.13.so
7f0f7129e000-7f0f712a2000 rw-p 00000000 00:00 0
7f0f712a2000-7f0f712a9000 r-xp 00000000 08:07 24063004 /usr/lib/libv4l2.so.0
7f0f712a9000-7f0f714a8000 ---p 00007000 08:07 24063004 /usr/lib/libv4l2.so.0
7f0f714a8000-7f0f714a9000 r--p 00006000 08:07 24063004 /usr/lib/libv4l2.so.0
7f0f714a9000-7f0f714ad000 rw-p 00007000 08:07 24063004 /usr/lib/libv4l2.so.0
7f0f714ad000-7f0f714b4000 r-xp 00000000 08:07 22831282 /lib/x86_64-linux-gnu/librt-2.13.so
7f0f714b4000-7f0f716b3000 ---p 00007000 08:07 22831282 /lib/x86_64-linux-gnu/librt-2.13.so
7f0f716b3000-7f0f716b4000 r--p 00006000 08:07 22831282 /lib/x86_64-linux-gnu/librt-2.13.so
7f0f716b4000-7f0f716b5000 rw-p 00007000 08:07 22831282 /lib/x86_64-linux-gnu/librt-2.13.so
7f0f716b5000-7f0f716f0000 r-xp 00000000 08:07 2283138Aborted
dpkg: error processing nspluginwrapper (--configure):
 subprocess installed post-installation script returned error exit status 134
dpkg: dependency problems prevent configuration of flashplugin-installer:
 flashplugin-installer depends on nspluginwrapper (>= 0.9.91.4-2ubuntu1); however:
  Package nspluginwrapper is not configured yet.
dpkg: error processing flashplugin-installer (--configure):
 dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of flashplugin-nonfree:
 flashplugin-nonfree depends on flashplugin-installer; however:
  Package flashplugin-installer is not configured yet.
  Package flashplugin64-installer which provides flashplugin-installer is not installed.
dpkg: error processing flashplugin-nonfree (--configure):
 dependency problems - leaving unconfigured
No apport report written because the error message indicates its a followup error from a previous failure.
                      No apport report written because the error message indicates its a followup error from a previous failure.
                                            Errors were encountered while processing:
 nspluginwrapper
 flashplugin-installer
 flashplugin-nonfree
E: Sub-process /usr/bin/dpkg returned an error code (1)
apu@apu-desktop:~$

Thanks for any help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Solved by:
wierdlmate@gmail.com
Solved:
2011-10-01
Last query:
2011-10-01
Last reply:
2011-09-30

This is fully updated natty.

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf'

Thanks

$ lsb_release -a; uname -a; dpkg -l | egrep 'flash|gnash|swf'
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty
Linux apu-desktop 2.6.38-11-generic #50-Ubuntu SMP Mon Sep 12 21:17:25 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux
iU flashplugin-installer 10.3.183.10ubuntu0.11.04.1 Adobe Flash Player plugin installer
iU flashplugin-nonfree 10.3.183.10ubuntu0.11.04.1 Adobe Flash Player plugin installer (transitional package)
rc flashplugin64-installer 11.0.1.129-0ubuntu0~sevenmachines1

In case it was needed, I installed now the lsb package, so I have

$ lsb_release -a
LSB Version: core-2.0-amd64:core-2.0-noarch:core-3.0-amd64:core-3.0-noarch:core-3.1-amd64:core-3.1-noarch:core-3.2-amd64:core-3.2-noarch:core-4.0-amd64:core-4.0-noarch:cxx-3.0-amd64:cxx-3.0-noarch:cxx-3.1-amd64:cxx-3.1-noarch:cxx-3.2-amd64:cxx-3.2-noarch:cxx-4.0-amd64:cxx-4.0-noarch:desktop-3.1-amd64:desktop-3.1-noarch:desktop-3.2-amd64:desktop-3.2-noarch:desktop-4.0-amd64:desktop-4.0-noarch:graphics-2.0-amd64:graphics-2.0-noarch:graphics-3.0-amd64:graphics-3.0-noarch:graphics-3.1-amd64:graphics-3.1-noarch:graphics-3.2-amd64:graphics-3.2-noarch:graphics-4.0-amd64:graphics-4.0-noarch:printing-3.2-amd64:printing-3.2-noarch:printing-4.0-amd64:printing-4.0-noarch:qt4-3.1-amd64:qt4-3.1-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.04
Release: 11.04
Codename: natty

sudo apt-get --purge remove flashplugin-installer flashplugin-nonfree

Should clean you up

sudo apt-get --purge remove flashplugin-installer flashplugin-nonfree

Should clean you up

Thanks. I also had purge/remove nspluginwrapper. Then I installed flashplugin64-installer, and all is well with the browsers. THANKS.