Adobe Flashplayer 10.3

Asked by Charles Maternus on 2011-07-11

I have the new Ubuntu 11.4, and I need to download the new Adobe Flashplayer 10.3, I have, but I can't open up videos. Ho2w do i open a flashplayer to watch videos?

Charlie

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu flashplugin-nonfree Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-13
Last reply:
2011-07-13

Flash videos are embedded in websites, so to watch a Flash video, you just go to the website that has the video. If this is not working for you, then please describe in detail and/or provide a link to the instructions you used to install Flash, and please also open a Terminal window (Ctrl+Alt+T) and run this command (by pasting it into the Terminal and pressing enter):

dpkg -l | egrep 'flash|gnash|swf|lightspark'

Charles Maternus (chmaternus) said : #2

I opened the terminal and pasted the command, and this was the response:

$ dpkg -l | egrep 'flash|gnash|swf|lightspark'
ii adobe-flashplugin
10.0.32.18-1 Adobe Flash Player plugin version 10

I checked the videos on the sites and it redirects me to:
http://get.adobe.com/flashplayer/...When I download APT for Ubuntu 10.04+, it
redirects me toa Launch application where Ubuntu Software Center.....and
Installed version that is highlighted.....I then hit OK and there
is no response.

I have upgraded Firefox to 5.0, does this have an impact.

To read your response, this tag popped up...Your browser must have Flash 9.0 or
higher installed to add this application. You can download and install the
latest Flash Player.......I closed your message, and obviously I have your
message.

I have shut down my PC, and I have rebooted my PC, but this has had no effect.

Thanks...Charlie

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Mon, July 11, 2011 3:01:27 PM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on Ubuntu changed:
https://answers.launchpad.net/ubuntu/+question/164387

    Status: Open => Answered

Eliah Kagan proposed the following answer:
Flash videos are embedded in websites, so to watch a Flash video, you
just go to the website that has the video. If this is not working for
you, then please describe in detail and/or provide a link to the
instructions you used to install Flash, and please also open a Terminal
window (Ctrl+Alt+T) and run this command (by pasting it into the
Terminal and pressing enter):

dpkg -l | egrep 'flash|gnash|swf|lightspark'

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+question/164387/+confirm?answer_id=0

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+question/164387

You received this question notification because you asked the question.

You've installed (and are attempting to use) quite an old version of the Adobe Flash plugin. (The current version is 10.3.181.34.)

There are a couple of ways to install the newer version that is commonly used with your Ubuntu release (Ubuntu 11.04 Natty Narwhal), but whatever way you use, you should first remove the old version you installed, which you can do by running this command:

sudo apt-get purge adobe-flashplugin

Then quit all web browser windows, then reopen your web browser and check to make sure that the Flash plugin is no longer listed. If your web browser is Firefox, you would do this by going to Tools > Add-Ons. Click Plugins on the left (if it's not already selected), and look for Flash in the list on the right. (The full name of the plugin is probably Shockwave Flash).

After verifying that the plugin was removed I recommend that you install the newer version by running this command:

sudo apt-get install flashplugin-installer

You'll have to quit all browser windows again (then relaunch your browser) to make that usable, after it's been installed.

Instead of installing it by running that command, you can also install it in the Software Center by installing the flashplugin-installer package, or in the Software Center by enabling the Partner repository and installing the adobe-flashplayer package. (But don't have both flashplugin-installer/flashplugin-nonfree and adobe-flashplugin at the same time!)

Finally, you had asked if using Firefox 5.0 makes a difference. The answer is that, with a new Flash plugin, it should work fine on Firefox 5.0, and with an old Flash plugin like the one you currently have installed, it might or might not work on any browser. (Old versions of the Flash plugin might also contain security vulnerabilities that have been discovered since they are released, which could put you at elevated risk.)

(By the way, in the future, you should avoid including the text of other people's messages when you post in a Launchpad question, because it makes it very difficult for people who are using the Launchpad web interface--which includes almost everyone who answers questions--to understand what is going on; if you're wondering what I mean, see https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387.)

Charles Maternus (chmaternus) said : #4

I don't think I'm quite there yet...Here's the response that I received. I
checked the plug ins and the Shockwave 10.0 r32 shows that it is disabled.

$ sudo apt-get purge adobe-flashplugin
[sudo] password for charlie:
Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_natty-security_main_i18n_Translation-en

E: The package lists or status file could not be parsed or opened.

Even though this didn't work, I did try the next command:

Reading package lists... Error!
E: Encountered a section with no Package: header
E: Problem with MergeList
/var/lib/apt/lists/security.ubuntu.com_ubuntu_dists_natty-security_main_i18n_Translation-en

E: The package lists or status file could not be parsed or opened.

Thanks...Charlie

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Mon, July 11, 2011 6:35:48 PM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on flashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

    Status: Open => Answered

Eliah Kagan proposed the following answer:
You've installed (and are attempting to use) quite an old version of the
Adobe Flash plugin. (The current version is 10.3.181.34.)

There are a couple of ways to install the newer version that is commonly
used with your Ubuntu release (Ubuntu 11.04 Natty Narwhal), but whatever
way you use, you should first remove the old version you installed,
which you can do by running this command:

sudo apt-get purge adobe-flashplugin

Then quit all web browser windows, then reopen your web browser and
check to make sure that the Flash plugin is no longer listed. If your
web browser is Firefox, you would do this by going to Tools > Add-Ons.
Click Plugins on the left (if it's not already selected), and look for
Flash in the list on the right. (The full name of the plugin is probably
Shockwave Flash).

After verifying that the plugin was removed I recommend that you install
the newer version by running this command:

sudo apt-get install flashplugin-installer

You'll have to quit all browser windows again (then relaunch your
browser) to make that usable, after it's been installed.

Instead of installing it by running that command, you can also install
it in the Software Center by installing the flashplugin-installer
package, or in the Software Center by enabling the Partner repository
and installing the adobe-flashplayer package. (But don't have both
flashplugin-installer/flashplugin-nonfree and adobe-flashplugin at the
same time!)

Finally, you had asked if using Firefox 5.0 makes a difference. The
answer is that, with a new Flash plugin, it should work fine on Firefox
5.0, and with an old Flash plugin like the one you currently have
installed, it might or might not work on any browser. (Old versions of
the Flash plugin might also contain security vulnerabilities that have
been discovered since they are released, which could put you at elevated
risk.)

(By the way, in the future, you should avoid including the text of other
people's messages when you post in a Launchpad question, because it
makes it very difficult for people who are using the Launchpad web
interface--which includes almost everyone who answers questions--to
understand what is going on; if you're wondering what I mean, see
https://answers.launchpad.net/ubuntu/+source/flashplugin-
nonfree/+question/164387.)

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387/+confirm?answer_id=2

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

You received this question notification because you asked the question.

Please do not include the text of the previous post, when you post replies. As I've mentioned, it clutters up the web interface and makes it difficult for people who are helping out with questions to understand what is going on. You can remove this text from the bottom of your email messages before hitting Send. (Or you can use the web interface yourself -- https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387 -- which never automatically includes the text of the last person's post.)

It seems that there is a problem with the cache package lists in your Ubuntu system. Please perform the steps listed in https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure, and see if that fixes the problem (i.e., after running the commands listed there, try running "sudo apt-get purge adobe-flashplugin" again, and if it succeeds, try running "sudo apt-get install flashplugin-installer").

If that doesn't fix the problem, then please post a reply here with the results. Please make sure to include *all* the text from the Terminal (including the lines related to "sudo apt-get purge adobe-flashplugin" and "sudo apt-get install flashplugin-installer" if you ran them).

Charles Maternus (chmaternus) said : #6

Here's the response

Preparing to replace libqt4-qt3support 4:4.7.2-0ubuntu6 (using .../libqt4-qt3support_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-qt3support ...
Preparing to replace libqt4-declarative 4:4.7.2-0ubuntu6 (using .../libqt4-declarative_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-declarative ...
Preparing to replace libqt4-sql 4:4.7.2-0ubuntu6 (using .../libqt4-sql_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-sql ...
Preparing to replace libqt4-xmlpatterns 4:4.7.2-0ubuntu6 (using .../libqt4-xmlpatterns_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-xmlpatterns ...
Preparing to replace libqt4-scripttools 4:4.7.2-0ubuntu6 (using .../libqt4-scripttools_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-scripttools ...
Preparing to replace libqt4-opengl 4:4.7.2-0ubuntu6 (using .../libqt4-opengl_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-opengl ...
Preparing to replace libqtgui4 4:4.7.2-0ubuntu6 (using .../libqtgui4_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqtgui4 ...
Preparing to replace libqt4-designer 4:4.7.2-0ubuntu6 (using .../libqt4-designer_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-designer ...
Preparing to replace libqt4-script 4:4.7.2-0ubuntu6 (using .../libqt4-script_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-script ...
Preparing to replace libqt4-network 4:4.7.2-0ubuntu6 (using .../libqt4-network_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-network ...
Preparing to replace libqt4-dbus 4:4.7.2-0ubuntu6 (using .../libqt4-dbus_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-dbus ...
Preparing to replace libqt4-xml 4:4.7.2-0ubuntu6 (using .../libqt4-xml_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-xml ...
Preparing to replace libqt4-test 4:4.7.2-0ubuntu6 (using .../libqt4-test_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqt4-test ...
Preparing to replace libqtcore4 4:4.7.2-0ubuntu6 (using .../libqtcore4_4%3a4.7.2-0ubuntu6.1_i386.deb) ...
Unpacking replacement libqtcore4 ...
Preparing to replace amarok-utils 2:2.4.0-0ubuntu5 (using .../amarok-utils_2%3a2.4.0-0ubuntu5.1_i386.deb) ...
Unpacking replacement amarok-utils ...
Preparing to replace libgpod4 0.8.0-2 (using .../libgpod4_0.8.0-2ubuntu0.1_i386.deb) ...
Unpacking replacement libgpod4 ...
Preparing to replace banshee 2.0.0-2ubuntu1 (using .../banshee_2.0.0-2ubuntu2_i386.deb) ...
Unpacking replacement banshee ...
Preparing to replace banshee-extension-soundmenu 2.0.0-2ubuntu1 (using .../banshee-extension-soundmenu_2.0.0-2ubuntu2_i386.deb) ...
Unpacking replacement banshee-extension-soundmenu ...
Preparing to replace banshee-extension-ubuntuonemusicstore 2.0.0-2ubuntu1 (using .../banshee-extension-ubuntuonemusicstore_2.0.0-2ubuntu2_i386.deb) ...
Unpacking replacement banshee-extension-ubuntuonemusicstore ...
Preparing to replace binutils 2.21.0.20110327-2ubuntu2 (using .../binutils_2.21.0.20110327-2ubuntu3_i386.deb) ...
Unpacking replacement binutils ...
Preparing to replace binutils-static 2.21.0.20110327-2ubuntu2 (using .../binutils-static_2.21.0.20110327-2ubuntu3_i386.deb) ...
Unpacking replacement binutils-static ...
Preparing to replace libnux-0.9-0 0.9.48-0ubuntu1 (using .../libnux-0.9-0_0.9.48-0ubuntu1.1_i386.deb) ...
Unpacking replacement libnux-0.9-0 ...
Preparing to replace libnux-0.9-common 0.9.48-0ubuntu1 (using .../libnux-0.9-common_0.9.48-0ubuntu1.1_all.deb) ...
Unpacking replacement libnux-0.9-common ...
Preparing to replace compiz-plugins-main 0.9.4+bzr20110406-0ubuntu2 (using .../compiz-plugins-main_0.9.4+bzr20110527-0ubuntu1~natty1_i386.deb) ...
Unpacking replacement compiz-plugins-main ...
Preparing to replace compiz-gnome 1:0.9.4+bzr20110415-0ubuntu2 (using .../compiz-gnome_1%3a0.9.4+bzr20110606-0ubuntu1~natty2_i386.deb) ...
Unpacking replacement compiz-gnome ...
Preparing to replace compiz-plugins 1:0.9.4+bzr20110415-0ubuntu2 (using .../compiz-plugins_1%3a0.9.4+bzr20110606-0ubuntu1~natty2_i386.deb) ...
Unpacking replacement compiz-plugins ...
Preparing to replace compiz-core 1:0.9.4+bzr20110415-0ubuntu2 (using .../compiz-core_1%3a0.9.4+bzr20110606-0ubuntu1~natty2_i386.deb) ...
Unpacking replacement compiz-core ...
Preparing to replace unity 3.8.12-0ubuntu1 (using .../unity_3.8.16-0ubuntu1~natty1_i386.deb) ...
Unpacking replacement unity ...
Preparing to replace unity-common 3.8.12-0ubuntu1 (using .../unity-common_3.8.16-0ubuntu1~natty1_all.deb) ...
Unpacking replacement unity-common ...
Preparing to replace nux-tools 0.9.48-0ubuntu1 (using .../nux-tools_0.9.48-0ubuntu1.1_i386.deb) ...
Unpacking replacement nux-tools ...
Preparing to replace libdecoration0 1:0.9.4+bzr20110415-0ubuntu2 (using .../libdecoration0_1%3a0.9.4+bzr20110606-0ubuntu1~natty2_i386.deb) ...
Unpacking replacement libdecoration0 ...
Preparing to replace compiz 1:0.9.4+bzr20110415-0ubuntu2 (using .../compiz_1%3a0.9.4+bzr20110606-0ubuntu1~natty2_all.deb) ...
Unpacking replacement compiz ...
Preparing to replace libcups2 1.4.6-5ubuntu1 (using .../libcups2_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcups2 ...
Preparing to replace libcupscgi1 1.4.6-5ubuntu1 (using .../libcupscgi1_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcupscgi1 ...
Preparing to replace libcupsdriver1 1.4.6-5ubuntu1 (using .../libcupsdriver1_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcupsdriver1 ...
Preparing to replace libcupsimage2 1.4.6-5ubuntu1 (using .../libcupsimage2_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcupsimage2 ...
Preparing to replace libcupsmime1 1.4.6-5ubuntu1 (using .../libcupsmime1_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcupsmime1 ...
Preparing to replace libcupsppdc1 1.4.6-5ubuntu1 (using .../libcupsppdc1_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement libcupsppdc1 ...
Preparing to replace cups-common 1.4.6-5ubuntu1 (using .../cups-common_1.4.6-5ubuntu1.3_all.deb) ...
Unpacking replacement cups-common ...
Preparing to replace cups-bsd 1.4.6-5ubuntu1 (using .../cups-bsd_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement cups-bsd ...
Preparing to replace cups-client 1.4.6-5ubuntu1 (using .../cups-client_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement cups-client ...
Preparing to replace cups-ppdc 1.4.6-5ubuntu1 (using .../cups-ppdc_1.4.6-5ubuntu1.3_i386.deb) ...
Unpacking replacement cups-ppdc ...
Preparing to replace cups 1.4.6-5ubuntu1 (using .../cups_1.4.6-5ubuntu1.3_i386.deb) ...
cups stop/waiting
Unpacking replacement cups ...
Preparing to replace cupsddk 1.4.6-5ubuntu1 (using .../cupsddk_1.4.6-5ubuntu1.3_all.deb) ...
Unpacking replacement cupsddk ...
Preparing to replace telepathy-logger 0.2.6-1ubuntu1 (using .../telepathy-logger_0.2.6-1ubuntu1.2_i386.deb) ...
Unpacking replacement telepathy-logger ...
Preparing to replace libtelepathy-logger2 0.2.6-1ubuntu1 (using .../libtelepathy-logger2_0.2.6-1ubuntu1.2_i386.deb) ...
Unpacking replacement libtelepathy-logger2 ...
Preparing to replace nautilus-sendto-empathy 2.34.0-0ubuntu3 (using .../nautilus-sendto-empathy_2.34.0-0ubuntu3.1_i386.deb) ...
Unpacking replacement nautilus-sendto-empathy ...
Preparing to replace empathy 2.34.0-0ubuntu3 (using .../empathy_2.34.0-0ubuntu3.1_i386.deb) ...
Unpacking replacement empathy ...
Preparing to replace empathy-common 2.34.0-0ubuntu3 (using .../empathy-common_2.34.0-0ubuntu3.1_all.deb) ...
Unpacking replacement empathy-common ...
Preparing to replace libevdocument3 2.32.0-0ubuntu12.1 (using .../libevdocument3_2.32.0-0ubuntu12.2_i386.deb) ...
Unpacking replacement libevdocument3 ...
Preparing to replace libevview3 2.32.0-0ubuntu12.1 (using .../libevview3_2.32.0-0ubuntu12.2_i386.deb) ...
Unpacking replacement libevview3 ...
Preparing to replace evince-common 2.32.0-0ubuntu12.1 (using .../evince-common_2.32.0-0ubuntu12.2_all.deb) ...
Unpacking replacement evince-common ...
Preparing to replace evince 2.32.0-0ubuntu12.1 (using .../evince_2.32.0-0ubuntu12.2_i386.deb) ...
Unpacking replacement evince ...
Preparing to replace firefox-globalmenu 4.0.1+build1+nobinonly-0ubuntu0.11.04.2 (using .../firefox-globalmenu_5.0+build1+nobinonly-0ubuntu0.11.04.2_i386.deb) ...
Unpacking replacement firefox-globalmenu ...
Preparing to replace firefox 4.0.1+build1+nobinonly-0ubuntu0.11.04.2 (using .../firefox_5.0+build1+nobinonly-0ubuntu0.11.04.2_i386.deb) ...
Unpacking replacement firefox ...
Preparing to replace firefox-gnome-support 4.0.1+build1+nobinonly-0ubuntu0.11.04.2 (using .../firefox-gnome-support_5.0+build1+nobinonly-0ubuntu0.11.04.2_i386.deb) ...
Unpacking replacement firefox-gnome-support ...
Selecting previously deselected package firefox-locale-en.
Unpacking firefox-locale-en (from .../firefox-locale-en_5.0+build1+nobinonly-0ubuntu0.11.04.2_all.deb) ...
Preparing to replace foo2zjs 20110210dfsg-1ubuntu2 (using .../foo2zjs_20110210dfsg-1ubuntu2.1_i386.deb) ...
Unpacking replacement foo2zjs ...
Preparing to replace gdm 2.32.1-0ubuntu3 (using .../gdm_2.32.1-0ubuntu3.2_i386.deb) ...
Unpacking replacement gdm ...
Preparing to replace libgimp2.0 2.6.11-1ubuntu6 (using .../libgimp2.0_2.6.11-1ubuntu6.1_i386.deb) ...
Unpacking replacement libgimp2.0 ...
Preparing to replace gimp-data 2.6.11-1ubuntu6 (using .../gimp-data_2.6.11-1ubuntu6.1_all.deb) ...
Unpacking replacement gimp-data ...
Preparing to replace gimp 2.6.11-1ubuntu6 (using .../gimp_2.6.11-1ubuntu6.1_i386.deb) ...
Unpacking replacement gimp ...
Preparing to replace glib-networking 2.28.5-0ubuntu1 (using .../glib-networking_2.28.6.1-0ubuntu1_i386.deb) ...
Unpacking replacement glib-networking ...
Preparing to replace gnome-nettool 2.32.0-0ubuntu1 (using .../gnome-nettool_2.32.0-0ubuntu1.1_i386.deb) ...
Unpacking replacement gnome-nettool ...
Preparing to replace gnome-user-guide 3.0.0+git20110406ubuntu9 (using .../gnome-user-guide_3.0.0+git20110406ubuntu10_all.deb) ...
Unpacking replacement gnome-user-guide ...
Preparing to replace language-selector 0.34 (using .../language-selector_0.34.2_all.deb) ...
Unpacking replacement language-selector ...
Preparing to replace libcurl3 7.21.3-1ubuntu1 (using .../libcurl3_7.21.3-1ubuntu1.2_i386.deb) ...
Unpacking replacement libcurl3 ...
Preparing to replace libgpod-common 0.8.0-2 (using .../libgpod-common_0.8.0-2ubuntu0.1_i386.deb) ...
Unpacking replacement libgpod-common ...
Preparing to replace libmodplug1 1:0.8.8.1-2 (using .../libmodplug1_1%3a0.8.8.1-2ubuntu0.2_i386.deb) ...
Unpacking replacement libmodplug1 ...
Preparing to replace ntrack-module-libnl-0 011-1ubuntu1 (using .../ntrack-module-libnl-0_011-1ubuntu1.1_i386.deb) ...
Unpacking replacement ntrack-module-libnl-0 ...
Preparing to replace libntrack0 011-1ubuntu1 (using .../libntrack0_011-1ubuntu1.1_i386.deb) ...
Unpacking replacement libntrack0 ...
Preparing to replace libntrack-qt4-1 011-1ubuntu1 (using .../libntrack-qt4-1_011-1ubuntu1.1_i386.deb) ...
Unpacking replacement libntrack-qt4-1 ...
Preparing to replace libxml2-utils 2.7.8.dfsg-2 (using .../libxml2-utils_2.7.8.dfsg-2ubuntu0.1_i386.deb) ...
Unpacking replacement libxml2-utils ...
Preparing to replace nautilus-sendto 2.32.0-0ubuntu1 (using .../nautilus-sendto_2.32.0-0ubuntu1.1_i386.deb) ...
Unpacking replacement nautilus-sendto ...
Preparing to replace python-libxml2 2.7.8.dfsg-2 (using .../python-libxml2_2.7.8.dfsg-2ubuntu0.1_i386.deb) ...
Unpacking replacement python-libxml2 ...
Preparing to replace python-papyon 0.5.5-1ubuntu1 (using .../python-papyon_0.5.5-1ubuntu1.2_all.deb) ...
Unpacking replacement python-papyon ...
Preparing to replace rdesktop 1.6.0-3ubuntu4 (using .../rdesktop_1.6.0-3ubuntu4.1_i386.deb) ...
Unpacking replacement rdesktop ...
Preparing to replace rhythmbox-plugins 0.13.3-0ubuntu5 (using .../rhythmbox-plugins_0.13.3-0ubuntu6_i386.deb) ...
Unpacking replacement rhythmbox-plugins ...
Preparing to replace rhythmbox 0.13.3-0ubuntu5 (using .../rhythmbox_0.13.3-0ubuntu6_i386.deb) ...
Unpacking replacement rhythmbox ...
Preparing to replace software-center 4.0.1 (using .../software-center_4.0.4_all.deb) ...
Unpacking replacement software-center ...
Preparing to replace thunderbird-globalmenu 3.1.10+build1+nobinonly-0ubuntu0.11.04.1 (using .../thunderbird-globalmenu_3.1.10+build1+nobinonly-0ubuntu0.11.04.2_i386.deb) ...
Unpacking replacement thunderbird-globalmenu ...
Preparing to replace thunderbird 3.1.10+build1+nobinonly-0ubuntu0.11.04.1 (using .../thunderbird_3.1.10+build1+nobinonly-0ubuntu0.11.04.2_i386.deb) ...
Unpacking replacement thunderbird ...
Preparing to replace xul-ext-ubufox 0.9-0ubuntu1 (using .../xul-ext-ubufox_0.9.1-0ubuntu0.11.04.1_all.deb) ...
Unpacking replacement xul-ext-ubufox ...
Preparing to replace ubufox 0.9-0ubuntu1 (using .../ubufox_0.9.1-0ubuntu0.11.04.1_all.deb) ...
Unpacking replacement ubufox ...
Preparing to replace unity-place-applications 0.2.46-0ubuntu3 (using .../unity-place-applications_0.2.46-0ubuntu3.1_i386.deb) ...
Unpacking replacement unity-place-applications ...
Preparing to replace unity-place-files 0.5.46-0ubuntu5 (using .../unity-place-files_0.5.46-0ubuntu5.1_i386.deb) ...
Unpacking replacement unity-place-files ...
Preparing to replace x11-common 1:7.6+4ubuntu3 (using .../x11-common_1%3a7.6+4ubuntu3.1_all.deb) ...
Unpacking replacement x11-common ...
Preparing to replace xserver-common 2:1.10.1-1ubuntu1 (using .../xserver-common_2%3a1.10.1-1ubuntu1.1_all.deb) ...
Unpacking replacement xserver-common ...
Preparing to replace xserver-xorg-core 2:1.10.1-1ubuntu1 (using .../xserver-xorg-core_2%3a1.10.1-1ubuntu1.1_i386.deb) ...
Unpacking replacement xserver-xorg-core ...
Preparing to replace xserver-xorg-video-radeon 1:6.14.0-0ubuntu4 (using .../xserver-xorg-video-radeon_1%3a6.14.0-0ubuntu4.1_i386.deb) ...
Unpacking replacement xserver-xorg-video-radeon ...
Preparing to replace xserver-xorg-video-ati 1:6.14.0-0ubuntu4 (using .../xserver-xorg-video-ati_1%3a6.14.0-0ubuntu4.1_i386.deb) ...
Unpacking replacement xserver-xorg-video-ati ...
Preparing to replace xserver-xorg-video-all 1:7.6+4ubuntu3 (using .../xserver-xorg-video-all_1%3a7.6+4ubuntu3.1_i386.deb) ...
Unpacking replacement xserver-xorg-video-all ...
Preparing to replace xserver-xorg-input-synaptics 1.3.99+git20110116.0e27ce3a-0ubuntu12 (using .../xserver-xorg-input-synaptics_1.3.99+git20110116.0e27ce3a-0ubuntu12.1_i386.deb) ...
Unpacking replacement xserver-xorg-input-synaptics ...
Preparing to replace xserver-xorg-input-all 1:7.6+4ubuntu3 (using .../xserver-xorg-input-all_1%3a7.6+4ubuntu3.1_i386.deb) ...
Unpacking replacement xserver-xorg-input-all ...
Preparing to replace xserver-xorg 1:7.6+4ubuntu3 (using .../xserver-xorg_1%3a7.6+4ubuntu3.1_i386.deb) ...
Unpacking replacement xserver-xorg ...
Preparing to replace xorg 1:7.6+4ubuntu3 (using .../xorg_1%3a7.6+4ubuntu3.1_i386.deb) ...
Unpacking replacement xorg ...
Preparing to replace compiz-fusion-plugins-main 0.9.4+bzr20110406-0ubuntu2 (using .../compiz-fusion-plugins-main_0.9.4+bzr20110527-0ubuntu1~natty1_all.deb) ...
Unpacking replacement compiz-fusion-plugins-main ...
Preparing to replace ubuntuone-control-panel-gtk 1.0.0-0ubuntu1 (using .../ubuntuone-control-panel-gtk_1.0.0-0ubuntu1.1_all.deb) ...
Unpacking replacement ubuntuone-control-panel-gtk ...
Preparing to replace ubuntuone-control-panel 1.0.0-0ubuntu1 (using .../ubuntuone-control-panel_1.0.0-0ubuntu1.1_all.deb) ...
Unpacking replacement ubuntuone-control-panel ...
Preparing to replace python-ubuntuone-control-panel 1.0.0-0ubuntu1 (using .../python-ubuntuone-control-panel_1.0.0-0ubuntu1.1_all.deb) ...
Unpacking replacement python-ubuntuone-control-panel ...
Preparing to replace shotwell 0.9.2-0ubuntu3 (using .../shotwell_0.9.3-0ubuntu0.1_i386.deb) ...
Unpacking replacement shotwell ...
Processing triggers for man-db ...
Processing triggers for ureadahead ...
ureadahead will be reprofiled on next reboot
Processing triggers for doc-base ...
Processing 3 changed doc-base file(s)...
Registering documents with scrollkeeper...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for desktop-file-utils ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for hicolor-icon-theme ...
Processing triggers for shared-mime-info ...
Unknown media type in type 'all/all'
Unknown media type in type 'all/allfiles'
Unknown media type in type 'uri/mms'
Unknown media type in type 'uri/mmst'
Unknown media type in type 'uri/mmsu'
Unknown media type in type 'uri/pnm'
Unknown media type in type 'uri/rtspt'
Unknown media type in type 'uri/rtspu'
Unknown media type in type 'interface/x-winamp-skin'
Processing triggers for gconf2 ...
Processing triggers for libglib2.0-0 ...
Processing triggers for ufw ...
Processing triggers for python-support ...
Setting up ntpdate (1:4.2.6.p2+dfsg-1ubuntu5.1) ...
Setting up apt-utils (0.8.13.2ubuntu4) ...
Setting up sudo (1.7.4p4-5ubuntu7.1) ...
Setting up initramfs-tools-bin (0.98.8ubuntu3.1) ...
Setting up initramfs-tools (0.98.8ubuntu3.1) ...
update-initramfs: deferring update (trigger activated)
Setting up libcurl3-gnutls (7.21.3-1ubuntu1.2) ...
Setting up apt-transport-https (0.8.13.2ubuntu4) ...
Setting up libxml2 (2.7.8.dfsg-2ubuntu0.1) ...
Setting up libisc62 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up libdns69 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up libisccc60 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up libisccfg62 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up libbind9-60 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up liblwres60 (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up bind9-host (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up dnsutils (1:9.7.3.dfsg-1ubuntu2.2) ...
Setting up python-apt-common (0.7.100.3ubuntu6.1) ...
Setting up python-apt (0.7.100.3ubuntu6.1) ...
Setting up language-selector-common (0.34.2) ...
Setting up language-selector-gnome (0.34.2) ...
Setting up amarok-common (2:2.4.0-0ubuntu5.1) ...
Setting up libqtcore4 (4:4.7.2-0ubuntu6.1) ...
Setting up amarok-utils (2:2.4.0-0ubuntu5.1) ...
Setting up libgpod4 (0.8.0-2ubuntu0.1) ...
Setting up libqt4-xml (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-dbus (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-network (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-script (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-sql (4:4.7.2-0ubuntu6.1) ...
Setting up libqtgui4 (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-svg (4:4.7.2-0ubuntu6.1) ...
Setting up amarok (2:2.4.0-0ubuntu5.1) ...
Setting up libqt4-sql-sqlite (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-sql-mysql (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-help (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-designer (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-qt3support (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-xmlpatterns (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-declarative (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-scripttools (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-opengl (4:4.7.2-0ubuntu6.1) ...
Setting up libqt4-test (4:4.7.2-0ubuntu6.1) ...
Setting up banshee (2.0.0-2ubuntu2) ...
Setting up banshee-extension-soundmenu (2.0.0-2ubuntu2) ...
Setting up banshee-extension-ubuntuonemusicstore (2.0.0-2ubuntu2) ...
Setting up binutils (2.21.0.20110327-2ubuntu3) ...
Setting up binutils-static (2.21.0.20110327-2ubuntu3) ...
Setting up libnux-0.9-common (0.9.48-0ubuntu1.1) ...
Setting up libnux-0.9-0 (0.9.48-0ubuntu1.1) ...
Setting up compiz-core (1:0.9.4+bzr20110606-0ubuntu1~natty2) ...
Setting up compiz-plugins-main (0.9.4+bzr20110527-0ubuntu1~natty1) ...
Setting up libdecoration0 (1:0.9.4+bzr20110606-0ubuntu1~natty2) ...
Setting up compiz-plugins (1:0.9.4+bzr20110606-0ubuntu1~natty2) ...
Setting up compiz-gnome (1:0.9.4+bzr20110606-0ubuntu1~natty2) ...
Setting up unity-common (3.8.16-0ubuntu1~natty1) ...
Setting up compiz (1:0.9.4+bzr20110606-0ubuntu1~natty2) ...
Setting up nux-tools (0.9.48-0ubuntu1.1) ...
Setting up unity (3.8.16-0ubuntu1~natty1) ...
Setting up libcups2 (1.4.6-5ubuntu1.3) ...
Setting up libcupscgi1 (1.4.6-5ubuntu1.3) ...
Setting up libcupsdriver1 (1.4.6-5ubuntu1.3) ...
Setting up libcupsimage2 (1.4.6-5ubuntu1.3) ...
Setting up libcupsmime1 (1.4.6-5ubuntu1.3) ...
Setting up libcupsppdc1 (1.4.6-5ubuntu1.3) ...
Setting up cups-common (1.4.6-5ubuntu1.3) ...
Setting up cups-client (1.4.6-5ubuntu1.3) ...
Setting up cups-bsd (1.4.6-5ubuntu1.3) ...
Setting up cups-ppdc (1.4.6-5ubuntu1.3) ...
Setting up cups (1.4.6-5ubuntu1.3) ...
cups start/running, process 8513
Setting up cupsddk (1.4.6-5ubuntu1.3) ...
Setting up libtelepathy-logger2 (0.2.6-1ubuntu1.2) ...
Setting up telepathy-logger (0.2.6-1ubuntu1.2) ...
Setting up empathy-common (2.34.0-0ubuntu3.1) ...
Setting up nautilus-sendto-empathy (2.34.0-0ubuntu3.1) ...
Setting up empathy (2.34.0-0ubuntu3.1) ...
Setting up libevdocument3 (2.32.0-0ubuntu12.2) ...
Setting up libevview3 (2.32.0-0ubuntu12.2) ...
Setting up evince-common (2.32.0-0ubuntu12.2) ...
Setting up evince (2.32.0-0ubuntu12.2) ...
Setting up firefox (5.0+build1+nobinonly-0ubuntu0.11.04.2) ...
Installing new version of config file /etc/apparmor.d/usr.bin.firefox ...
Installing new version of config file /etc/apport/blacklist.d/firefox ...
Please restart all running instances of firefox, or you will experience problems.
Setting up firefox-globalmenu (5.0+build1+nobinonly-0ubuntu0.11.04.2) ...
Setting up firefox-gnome-support (5.0+build1+nobinonly-0ubuntu0.11.04.2) ...
Setting up firefox-locale-en (5.0+build1+nobinonly-0ubuntu0.11.04.2) ...
Setting up foo2zjs (20110210dfsg-1ubuntu2.1) ...
Setting up gdm (2.32.1-0ubuntu3.2) ...
Setting up libgimp2.0 (2.6.11-1ubuntu6.1) ...
Setting up gimp-data (2.6.11-1ubuntu6.1) ...
Setting up gimp (2.6.11-1ubuntu6.1) ...
Setting up glib-networking (2.28.6.1-0ubuntu1) ...
Setting up gnome-nettool (2.32.0-0ubuntu1.1) ...
Setting up gnome-user-guide (3.0.0+git20110406ubuntu10) ...
Setting up language-selector (0.34.2) ...
Setting up libcurl3 (7.21.3-1ubuntu1.2) ...
Setting up libgpod-common (0.8.0-2ubuntu0.1) ...
Setting up libmodplug1 (1:0.8.8.1-2ubuntu0.2) ...
Setting up libxml2-utils (2.7.8.dfsg-2ubuntu0.1) ...
Setting up nautilus-sendto (2.32.0-0ubuntu1.1) ...
Setting up python-libxml2 (2.7.8.dfsg-2ubuntu0.1) ...
Setting up python-papyon (0.5.5-1ubuntu1.2) ...
Setting up rdesktop (1.6.0-3ubuntu4.1) ...
Setting up rhythmbox (0.13.3-0ubuntu6) ...
Setting up rhythmbox-plugins (0.13.3-0ubuntu6) ...
Setting up software-center (4.0.4) ...
Updating software catalog...this may take a moment.
Software catalog update was successful.
Setting up thunderbird (3.1.10+build1+nobinonly-0ubuntu0.11.04.2) ...
Setting up thunderbird-globalmenu (3.1.10+build1+nobinonly-0ubuntu0.11.04.2) ...
Setting up xul-ext-ubufox (0.9.1-0ubuntu0.11.04.1) ...
Setting up ubufox (0.9.1-0ubuntu0.11.04.1) ...
Setting up unity-place-applications (0.2.46-0ubuntu3.1) ...
Installing new version of config file /etc/xdg/menus/unity-place-applications.menu ...
Setting up unity-place-files (0.5.46-0ubuntu5.1) ...
Setting up x11-common (1:7.6+4ubuntu3.1) ...
Setting up xserver-common (2:1.10.1-1ubuntu1.1) ...
Setting up xserver-xorg-core (2:1.10.1-1ubuntu1.1) ...
Setting up xserver-xorg-video-radeon (1:6.14.0-0ubuntu4.1) ...
Setting up xserver-xorg-video-ati (1:6.14.0-0ubuntu4.1) ...
Setting up xserver-xorg-video-all (1:7.6+4ubuntu3.1) ...
Setting up xserver-xorg-input-synaptics (1.3.99+git20110116.0e27ce3a-0ubuntu12.1) ...
Setting up xserver-xorg-input-all (1:7.6+4ubuntu3.1) ...
Setting up xserver-xorg (1:7.6+4ubuntu3.1) ...
Setting up xorg (1:7.6+4ubuntu3.1) ...
Setting up compiz-fusion-plugins-main (0.9.4+bzr20110527-0ubuntu1~natty1) ...
Setting up python-ubuntuone-control-panel (1.0.0-0ubuntu1.1) ...
Setting up ubuntuone-control-panel (1.0.0-0ubuntu1.1) ...
Setting up ubuntuone-control-panel-gtk (1.0.0-0ubuntu1.1) ...
Setting up shotwell (0.9.3-0ubuntu0.1) ...
Setting up language-pack-en (1:11.04+20110607) ...
Setting up libntrack0 (011-1ubuntu1.1) ...
Setting up ntrack-module-libnl-0 (011-1ubuntu1.1) ...
Setting up libntrack-qt4-1 (011-1ubuntu1.1) ...
Setting up language-pack-en-base (1:11.04+20110607) ...
Generating locales...
  en_AG.UTF-8... up-to-date
  en_AU.UTF-8... up-to-date
  en_BW.UTF-8... up-to-date
  en_CA.UTF-8... up-to-date
  en_DK.UTF-8... up-to-date
  en_GB.UTF-8... up-to-date
  en_HK.UTF-8... up-to-date
  en_IE.UTF-8... up-to-date
  en_IN.UTF-8... up-to-date
  en_NG.UTF-8... up-to-date
  en_NZ.UTF-8... up-to-date
  en_PH.UTF-8... up-to-date
  en_SG.UTF-8... up-to-date
  en_US.UTF-8... up-to-date
  en_ZA.UTF-8... up-to-date
  en_ZW.UTF-8... up-to-date
Generation complete.
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Setting up language-pack-gnome-en (1:11.04+20110607) ...
Setting up language-pack-kde-en (1:11.04+20110607) ...
Setting up language-pack-gnome-en-base (1:11.04+20110607) ...
Setting up language-pack-kde-en-base (1:11.04+20110607) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-2.6.38-8-generic-pae
Processing triggers for python-support ...
Processing triggers for python-central ...
Processing triggers for python-gmenu ...
Rebuilding /usr/share/applications/desktop.C.cache...
Processing triggers for bamfdaemon ...
Rebuilding /usr/share/applications/bamf.index...
Processing triggers for python-support ...
charlie@charlie-laptop:~$

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Monday, July 11, 2011 9:31 PM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on flashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

    Status: Open => Answered

Eliah Kagan proposed the following answer:
Please do not include the text of the previous post, when you post
replies. As I've mentioned, it clutters up the web interface and makes
it difficult for people who are helping out with questions to understand
what is going on. You can remove this text from the bottom of your email
messages before hitting Send. (Or you can use the web interface yourself
-- https://answers.launchpad.net/ubuntu/+source/flashplugin-
nonfree/+question/164387 -- which never automatically includes the text
of the last person's post.)

It seems that there is a problem with the cache package lists in your
Ubuntu system. Please perform the steps listed in
https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure,
and see if that fixes the problem (i.e., after running the commands
listed there, try running "sudo apt-get purge adobe-flashplugin" again,
and if it succeeds, try running "sudo apt-get install flashplugin-
installer").

If that doesn't fix the problem, then please post a reply here with the
results. Please make sure to include *all* the text from the Terminal
(including the lines related to "sudo apt-get purge adobe-flashplugin"
and "sudo apt-get install flashplugin-installer" if you ran them).

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387/+confirm?answer_id=4

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

You received this question notification because you asked the question.

Charles Maternus (chmaternus) said : #7

Here's the second part of

Here's the second part of the command that you instructed me to do....

sudo apt-get purge adobe-flashplugin
[sudo] password for charlie:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libnss3-dev libnspr4-dev
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  adobe-flashplugin*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
After this operation, 10.4 MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 185658 files and directories currently installed.)
Removing adobe-flashplugin ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing adobe-flashplugin (--purge):
 subprocess installed pre-removal script returned error exit status 2
postinst called with argument `abort-remove'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)
charlie@charlie-laptop:~$ sudo apt-get install flashplugin
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package flashplugin is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  adobe-flashplugin flashplugin-installer

E: Package 'flashplugin' has no installation candidate

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Monday, July 11, 2011 9:31 PM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on flashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

    Status: Open => Answered

Eliah Kagan proposed the following answer:
Please do not include the text of the previous post, when you post
replies. As I've mentioned, it clutters up the web interface and makes
it difficult for people who are helping out with questions to understand
what is going on. You can remove this text from the bottom of your email
messages before hitting Send. (Or you can use the web interface yourself
-- https://answers.launchpad.net/ubuntu/+source/flashplugin-
nonfree/+question/164387 -- which never automatically includes the text
of the last person's post.)

It seems that there is a problem with the cache package lists in your
Ubuntu system. Please perform the steps listed in
https://help.ubuntu.com/community/PackageManagerTroubleshootingProcedure,
and see if that fixes the problem (i.e., after running the commands
listed there, try running "sudo apt-get purge adobe-flashplugin" again,
and if it succeeds, try running "sudo apt-get install flashplugin-
installer").

If that doesn't fix the problem, then please post a reply here with the
results. Please make sure to include *all* the text from the Terminal
(including the lines related to "sudo apt-get purge adobe-flashplugin"
and "sudo apt-get install flashplugin-installer" if you ran them).

--
If this answers your question, please go to the following page to let us
know that it is solved:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387/+confirm?answer_id=4

If you still need help, you can reply to this email or go to the
following page to enter your feedback:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

You received this question notification because you asked the question.

When you ran "sudo apt-get purge adobe-flashplugin", did you have any web browser windows open? If so, please close all web browser windows and run that command again, and post the results.

Charles Maternus (chmaternus) said : #9

I made sure the browser and all applications were closed; here's the response....

1,,,Would it be worthwhile to dump the Ubuntu and reboot it?

2...If so, can I do it in the terminal?

Charlie

sudo apt-get purge adobe-flashplugin
[sudo] password for charlie:
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  libnss3-dev libnspr4-dev
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  adobe-flashplugin*
0 upgraded, 0 newly installed, 1 to remove and 0 not upgraded.
1 not fully installed or removed.
After this operation, 10.4 MB disk space will be freed.
Do you want to continue [Y/n]? Y
(Reading database ... 185658 files and directories currently installed.)
Removing adobe-flashplugin ...
update-alternatives: error: no alternatives for iceape-flashplugin.
update-alternatives: error: no alternatives for iceape-flashplugin.
dpkg: error processing adobe-flashplugin (--purge):
 subprocess installed pre-removal script returned error exit status 2
postinst called with argument `abort-remove'
dpkg: error while cleaning up:
 subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
 adobe-flashplugin
E: Sub-process /usr/bin/dpkg returned an error code (1)

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Tuesday, July 12, 2011 1:56 AM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on flashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

    Status: Open => Needs information

Eliah Kagan requested more information:
When you ran "sudo apt-get purge adobe-flashplugin", did you have any
web browser windows open? If so, please close all web browser windows
and run that command again, and post the results.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

You received this question notification because you asked the question.

Charles Maternus (chmaternus) said : #10

My Adobe is flashplayer is working now.....Here's the command that I used...

sudo apt-get install flashplugin-nonfree

Thanks for your patience....Charlie

________________________________
From: Eliah Kagan <email address hidden>
To: <email address hidden>
Sent: Tuesday, July 12, 2011 1:56 AM
Subject: Re: [Question #164387]: Adobe Flashplayer 10.3

Your question #164387 on flashplugin-nonfree in Ubuntu changed:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

    Status: Open => Needs information

Eliah Kagan requested more information:
When you ran "sudo apt-get purge adobe-flashplugin", did you have any
web browser windows open? If so, please close all web browser windows
and run that command again, and post the results.

--
To answer this request for more information, you can either reply to
this email or enter your reply at the following page:
https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387

You received this question notification because you asked the question.

If your problem is now fixed, please mark this question as Solved. (You can do that at https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387.) The rest of this post is just some explanation for what's going on, focused on providing information to fall back on if you experience future Flash breakage on your system.

In post #7 (numbered at https://answers.launchpad.net/ubuntu/+source/flashplugin-nonfree/+question/164387), you had run the command "sudo apt-get install flashplugin" instead of "sudo apt-get install flashplugin-installer". The command "sudo apt-get install flashplugin" had no effect because there is no package that matches the name "flashplugin". The command "sudo apt-get install flashplugin-installer" generally has the same effect as the command "sudo apt-get install flashplugin-nonfree". So you have now, in effect, performed the step for installing the new version of Flash. But the command "sudo apt-get purge adobe-flashplugin" had failed, so you may very well still have the old Flash plugin still installed.

Having multiple versions of Flash installed tends to cause problems. If you don't have any problems with Flash anymore, you can ignore this--just keep this situation in mind, in case they arise later. If they do (or if you feel like dealing with it now), then you should try to remove the adobe-flashplugin package (even if you cannot remove it along with its configuration files, which is what "purge" does):

sudo apt-get remove adobe-flashplugin

If that fails, then alternatively (and you should probably only do this if things stop working right, since this involves removing your currently working Flash plugin), you could:

(1) Remove flashplugin-installer and flashplugin-nonfree (generally speaking, they will both be installed):

sudo apt-get purge flashplugin-installer
sudo apt-get purge flashplugin-nonfree

(Don't worry if one of them is indicated not to have been installed when you tried to purge it.)

(2) Enable the Canonical partner repository (https://help.ubuntu.com/community/Repositories/Ubuntu#Adding%20Canonical%20Partner%20Repositories).

(3) Attempt to upgrade the old version of adobe-flashplugin that you had installed to the new version provided by the Canonical partner repository:

sudo apt-get install adobe-flashplugin

(Please note that just updating the software on your system, for example with the Update Manager, might be sufficient to do the trick.)

Can you help with this problem?

Provide an answer of your own, or ask Charles Maternus for more information if necessary.

To post a message you must log in.