Uninstalled Firestarter now I cannot get to Internet

Asked by jmccracken on 2009-12-13

I recently uninstalled Firesarter from Intrepid 8.10 64bit, now I cannot get to the Internet.

Conditions:
     1. Firestarter was set to start and block all attempts to send or receive at boot-up.
     2. Auto Eth connects and enables networking for the system (according to icon in top panel and connection info applet).
     3. Guardog was also installed but never configured (it was uninstalled at same time as Firestarter)
     4. I did not reconfigure Firestarter to allow traffic before uninstalling.
         (I consider this a bug but some would consider it a security advantage where kids are concerned).

Actions Taken:
     1. Removed all Firestarter files and dirs (that I could find in a search).
     2. Removed all Firestarter scripts from init.d and links from rcS.d

Status: Problem Persists

Request assistence to resolve condition (if possible).

Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firestarter Edit question
Assignee:
No assignee Edit question
Solved by:
jmccracken
Solved:
2009-12-16
Last query:
2009-12-16
Last reply:
2009-12-14

You can either:

#1. Using an Internet-connected system, download the Firestarter package from http://packages.ubuntu.com/intrepid/firestarter. Install it on your system, reconfigure Firestarter to allow everything, et voila.

#2. Use the iptables command to allow everything by default:

sudo iptables -P INPUT ACCEPT
sudo iptables -F INPUT
sudo iptables -P OUTPUT ACCEPT
sudo iptables -F OUTPUT

And then report the output of "iptables -L -n"; there may be some more rules to remove.

jmccracken (j-g-mccracken) said : #2

Thank you Danilo Piazzalunga,

I will give that a try. I had a similar idea to download from the Firestarter website. I tried to install it from a tarball but received errors about dhcp3-server package, then one for dhcp-common package. Synaptic reported the same. I now have a sneaking feeling something is really screwed up this time.

Additional Info:
During a previous system update at approx. 2:30 a.m. Central I ran into some problems updating from a Canonical 'Main' server (aukland.canonical.com). It seems my system would just stop and do nothing for 5 to 10 minutes then resume at about 1024 bytes per second or less (on a 1.5 mb/s connection). I cancelled the update and tried 3 more times to complete it (when ever it got to the linux-kernel or linux-headers packages it would slow to the previously mentioned condition). It was after removing Firestarter and restarting to try and complete the updates that the problems surfaced.

Your solution sounds viable and I will give it a go and get back to you.

Thanks again.

Why download the upstream tarball when you can install the Ubuntu package?

If firestarer does not install because of some missing dependencies, you will have to go to http://packages.ubuntu.com/intrepid/firestarter again and then download the required .deb packages.

jmccracken (j-g-mccracken) said : #4

Thanks again Danilo Piazzalunga,

There is a mis-understanding, I had already tried my approach when I got your solution. I knew there was away to do it your way but did not have the repository address. Then you sent the address and that made all the difference.

I downloaded the Ubuntu package and the dhcp3-server package just in case I needed them and it worked like a charm.

Many Thanks and Blessings to you Danilo Piazzalunga!