firestarter installation in linux mint

Asked by j,jackson on 2009-08-12

How do I install firestarter firewall in Mint Gloria ?
I have done exactly as suggested in LXF Magazine but although the programme is shown in the Internet panel in Applications when I click on it nothing happens at all. If I go into Control Centre/System: its in there but when I click on that a panel comes up with the Wizard in it which I follow until it says "save" when I click on that every thing goes back to the beginning as though I have not done anything.
                                                                                        Anyone cured this problem ?
                                                                                                                                      jj

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firestarter Edit question
Assignee:
No assignee Edit question
Solved by:
Tom
Solved:
2009-08-13
Last query:
2009-08-13
Last reply:
2009-08-12
Best Tom (tom6) said : #1

Hi :)

Note that the firewall is running right from a standard install even though you can't get the gui front-end to work. Anyway linux is pretty safe even without all that protection which would be vital in Windows
https://help.ubuntu.com/community/Antivirus
https://help.ubuntu.com/community/SwitchingToUbuntu/FromWindows

Mint has it's own user forums at
http://forums.linuxmint.com/
which might be more helpful about this. Mint is based on Ubuntu tho so i guess some people here would be happy to try to help you but i would advise copy&paste this question into the Mint forums too ;)

Can you get to a command-line in Mint and type in

firestarter

and then post any output it gives (except ip addresses) into this forum?
Thanks, good luck and regards from
Tom :)

j,jackson (jonjac3) said : #2

Thanks Tom, that solved my question.

Tom (tom6) said : #3

Wow!! Nicely done :)))
Please let us know how you fixed this very briefly, just enough of a hint to help anyone with the same problem in the future. Thanks
Coingrats and regards from
Tom :)

j,jackson (jonjac3) said : #4

Tom,
I typed Firestarter in terminal then sudo apt-get install firestarter, it loaded it. I then rebooted and screen came up with
/usr/bin/firestarter. lets you modify essential parts of comp: I entered password & the wizard came up , I ran that clicked on save & that put a firestarter window up I pressed on start and icon appeared in toolbar, I then clicked on minimise to get rid of window on desktop and it left icon in toolbar. so it seems ok
                                                                                                                      j.j

Tom (tom6) said : #5

Brilliant! Thanks for that, hopefully it should help someone else if/when they run into the same problem.

Thanks and regards from
Tom :))

Manny Guy (mannyguy1) said : #6

The firewall is started on install automatically by the "apt-get install firestarter" command, the problem seems the menu buttom installed in Mint, which does'nt bring up the Firestarter GUI correctly. To correct in Mint, click Menu, Control Center, Main Menu. Click on the Administration menu to bring up the Administration menu items, which includes Firestarter. Right click on Firestarter to bring up the Launcher properites. The correct command to bring up the GUI is "su-to-root -X -c /usr/sbin/firestarter". Click close, then close again to close the menu items. Now when you click Firestarter on the Mint menu, it will corectly prompt for the password and launch the Firestarter GUI appropriately.

Tom (tom6) said : #7

Manny,

Thanks for the answer there but i think this is an old question that has been solved satisfactorily already.

It is always great to have extra technical detail added and that should help people in the future with the same problem (if 1 person has trouble then its likely that others will too)

I'm looking forward to Ubuntu 10.04 LTS release in a months time!! :))

Many thanks and regards from
Tom :)