Firestarter will not schare connection over wireless - wlan0 is not ready

Asked by jamiehay on 2009-01-11

When trying to configure firestarter for ICS it always says device wlan0 is not ready.

why is it not ready?? whats wrong with it?? and how do I fix it??

2 weeks an counting, still no answers please someone help me

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firestarter Edit question
Assignee:
No assignee Edit question
Last query:
2009-01-11
Last reply:
2009-01-11
Jimbo (james-saveker) said : #1

I tried the following fix myself and it worked (from the Ubuntu Firestarter Docs).... let me know how you get on.

Apparently there is a conflict between Firestarter and Network manager.

The "fix" is to edit /etc/firestarter/firestarter.sh

gksu gedit /etc/firestarter/firestarter.sh

Comment out :

if [ "$MASK" = "" -a "$1" != "stop" ]; then
echo "External network device $IF is not ready. Aborting.."
exit 2
fi

Like this:

#if [ "$MASK" = "" -a "$1" != "stop" ]; then
#echo "External network device $IF is not ready. Aborting.."
#exit 2
#fi

Save your changes and re-boot.

Can you help with this problem?

Provide an answer of your own, or ask jamiehay for more information if necessary.

To post a message you must log in.