firestarter insufficient priveleges on startup

Asked by Richard Reinhart on 2008-01-27

I am attempting to run Firestarter on startup. I placed Firestarter in the System--sessions--startup, but when boot up I receive the error message "Insufficient Priveleges, you must have root user priveleges to use Firestarter"

How can I start Firestarter on boot up?
Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firestarter Edit question
Assignee:
No assignee Edit question
Solved by:
Richard Reinhart
Solved:
2009-10-17
Last query:
2009-10-17
Last reply:
2009-10-16
Richard Reinhart (reinhartr) said : #2

Using gedit to edit the file /etc/sudoers, I receive the error message:
"Could not open the file /etc/sudoers. You do not have permission necessary to open file".

It looks like I somehow need to tell the editing program or change the file temporarily to one that I can edit without root priveleges or somehow tell the program that I have root priveleges?

Thanks

Vadim Peretokin (vperetokin) said : #3

Yep, you do - just add the "gksudo" command before.

So if you did "gedit /etc/sudoers" before, doing "gksudo gedit /etc/sudoers" will do the trick.

Richard Reinhart (reinhartr) said : #4

This command opens the file and I can add "username ALL= NOPASSWD: /usr/bin/firestarter ", but am unable to save the changes since this is a read only file. I am unable to change the permissions since I am not an owner of the file.

How do I save these changes that I make to sudoers
Thanks,
RR

Richard Reinhart (reinhartr) said : #5

I receive the error message "You are trying to save the file on a read-only disk. Please check that you typed the location correctly and try again."

Richard Reinhart (reinhartr) said : #7

The command in terminal "sudo visudo" allowed access to the file and ability to save. Adding "username ALL= NOPASSWD: /usr/bin/firestarter " worked after finding the and inserting the appropriate location of firestarter (right click on the icon in system tray and check properties for the exact location of the file) which for me is /usr/sbin/firestarter and may be different for different versions of ubuntu.

It now works.

Now if I can just get it to load minimized.

Thanks for the help,
RR