Firestarter failed to open the system log

Asked by Mannex on 2011-05-03

Installed Firestarter 1.0.3 under 11.04. Firestarter reports error on startup:

 Failed to open the system log
 No event information will be available.

As predicted by the message, there is no event logging. Why can't it access the logs? Also, Log File Viewer reports errors attempting to open almost every log file. Both are being run as root, so why the problem? Any help will be greatly appreciated. Thanks!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firestarter Edit question
Assignee:
No assignee Edit question
Solved by:
Keith Taylor
Solved:
2011-05-05
Last query:
2011-05-05
Last reply:
2011-05-03

Have you logged a bug?

Its not a bug, a feature :)

There is a missing file from older Ubuntu distributions.

It looks like Ubuntu 11.04 installs rsylogd rather than syslogd. This uses the file /etc/rsyslog.conf which references the file configuration /etc/rsyslog.d/50-default.conf.

You can edit this file and change the lines commented out that create the relevant logfile

#*.=info;*.=notice;*.=warn;\
# auth,authpriv.none;\
# cron,daemon.none;\
# mail,news.none -/var/log/messages

to

*.=info;*.=notice;*.=warn;\
        auth,authpriv.none;\
        cron,daemon.none;\
        mail,news.none -/var/log/messages

and then restart rsyslog or reboot

Hope this help
--

A missing file is a bug. The package should install and create the files needed so that the app can work.

Please site this as a fix and the package will get updated to do this automagically

Mannex (russ-mannex) said : #4

Thanks for the responses. My configure file already had the old section commented out, but there was no replacement section for messages, so I added it. As soon as my machine is done doing some other mundane and uninterruptable things, I'll reboot and let y'all know how it goes!

Mannex (russ-mannex) said : #5

OK, making the changes above fixed it for me. Of course, it's still a bug :)

Mannex (russ-mannex) said : #6

Thanks Keith Taylor, that solved my question.

Mannex (russ-mannex) said : #7

Please note that this is still broken in 11.10.

joopie (krusty-the4clown) said : #8

And still in 13.04