internet browsers refuse to go to the URLS i direct them to

Asked by remz on 2009-11-20

Often and at random whenever I type in a URL, or follow one, i find myself not at the page inteded.

for example, instead of going to https://bugs.launchpad.net/ubuntu/ I'll find myself at a random page, for example, a google branded one informing me that "/ubuntu could not be found on this server" or for awhile there, trying to get to facebook i would instead get directed to the Google homepage.

used to use ubuntu back in the hardy days without any troubles, this has come up recently.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
remz
Solved:
2009-11-22
Last query:
2009-11-22
Last reply:
2009-11-22

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a kernel bug. For now I'm converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense for this particular issue to be raised in the support tracker at https://answers.launchpad.net/ubuntu. Thanks.

Wim (launchpad-xs4all) said : #2

Remz,

it seems to me that the name-of-the-site is set to the wrong ip-number:
normally if you want to go to ubuntu.com,
then linux first looks in the file /etc/hosts if there is an item ubuntu.com (it is not...),
if YES,
then the ip-number from that line is used;
if NOT, then linux asks the string "ubuntu.com" to the DNS-server on your network, and uses the ip-number it gets from the DNS-server.

Reading your story, it seems that either the DNS-server is set wrong on your PC, or ...
the browser doesnt ask the ip-address on the DNS-server, but on an other program or on an other site.

Sometimes you can install a taskbar in a browser giving you several features; disadvantage is, that some of them doesnt browse directly anymore, but via the site where they came from (google is such an example)

So check:
1 the file /etc/hosts doesnt state any site-names you have trouble with
2 in <Networks> the DNS-setting is correct
3. in your browser the connection-info and DNS-server(s) are correct

Hopes this helps you...

remz (remy-perona) said : #3

Thanks for the help everyone.

I ended up reinstalling ubuntu and starting over, things seem to be working fine now, I think somewhere along the line an upgrade must've screwed something with the DNS.

All good now though.

David Jones (dj) said : #4

rty using question solved please.

remz (remy-perona) said : #5

It's already marked as question solved, isn't it?

remz (remy-perona) said : #6

@ Whoever moved it: It wasn't a firefox problem. It happened in all browsers, everything from opera, to empathy, to konquerer to Chromium .

It was definitely a DNS problem, and I have now rectified it.