I'm new and I need help viewing certain web pages on firefox.

Asked by fleetothecleve on 2009-04-29

My brother recently installed the latest version of Ubuntu on my computer after I had some serious problems with windows xp. I'm not a techie guy by any means and now I'm having trouble viewing certain streams on a lot of web pages. I'm sure I'm just missing some kind of plug-in, but I don't know where to find it.

Here's an exemple of a website I can only see parts of:

http://mlb.mlb.com/index.jsp

The streaming parts of the site all show up as big "Play" buttons, but I can still read all the text. Please help me if you have seen and fixed this problem before.

Thanks!!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Mike Matis
Solved:
2009-04-30
Last query:
2009-04-30
Last reply:
2009-04-30

This question was reopened

peter (peter-neuweiler) said : #1

Strange. I had a look at http://mlb.mlb.com/index.jsp and it looks ok.

Which version of Firefox do you have? 3.0.10 is the final release. Do you use the Update Manager to get the latest updates?
Peter

I actually have Firefox 3.0.9. Should I update it? And, how do I use the update manager?

peter (peter-neuweiler) said : #3

To use the Update Manager:

1: Click System > Administration > Update Manager (now it's checking for updates).
If you have updates, install them.

2: Click Check (a second repository will be checked)
If you have updates, install them.

Firefox should be upgraded to 3.0.10 via the Update Manager. I got it yesterday.
Peter

OK..I got that now, and firefox is updated. Now most of the streaming windows are opening, as long as I hit the "play" button first. Some are still just blank white squares though. I'm also having trouble watching some streaming video, specifically ones the my Windows Media Player supported when I had XP. Any idea what I can do about that??

Thanks again
Tim

Shahar Or (mightyiam) said : #5

Dear fleetothecleve,

The big play buttons sound like the Flashblock extension for Firefox. Try right clicking on one of them in the site and "Allow flash from this site" and then reload the page (F5).

Okay, the play buttons seem to be gone now. Now how do I get some of these videos to play? Like the ones on CNN.com. I intalled MPlayer and Adobe Flash for Ubuntu, and they're still not playing. I read something about "sudo apt-get install flashplugin-nonfree", but I have no idea what that means or how to install it properly.

Shahar Or (mightyiam) said : #7

Dear fleetothecleve,

In Ubuntu and other linux distributions, the method for installing things is not like in windows. So one should not download packages from websites and install them in the computer. Instead, there's a packaging system which one should use to install packages from an repository.

How did you install MPlayer and Adobe Flash, please?

I found Ubuntu/Linux versions of Adobe Flash and MPlayer and downloaded them. Then I went into Add/Remove under applications and had my computer install them. MPlayer seems to work, but I'm basically lost at this point. Should I uninstall them?

Shahar Or (mightyiam) said : #9

If you installed them from the package manager and not from the manually downloaded packages your system should be ok.

Lets be more specific. Give me a link to something that doesn't work, please.

Here's the link to CNN videos.

http://www.cnn.com/video/

The link to the Live Video Stream doesn't connect and the page never really finishes loading even though it says it's done. All I see is a black square where a video should be available to watch.

Mike Matis (mmatis) said : #11

After Installing the flash plugin, did you close all of your firefox windows, and re-open it again? After doing so, go to http://www.adobe.com/products/flashplayer/

Hopefully you'll see a spiffy little movie. If not, then flash is not properly installed. Let us know what happens, and we'll go from there.

Shahar Or (mightyiam) said : #12

Try...

http://edition.cnn.com/video/

And just disable that flashblock extension.

the flashblock extension is disabled, but the video still isn't showing. The video on http://www.adobe.com/products/flashplayer/ is working however. Do you think there's something else I still need to install or disable/enable?

Mike Matis (mmatis) said : #14

I wracking my brain because I've had this same problem before. Does YouTube work? Are you by chance using the 64 bit version of Ubuntu?

Best Mike Matis (mmatis) said : #15

OK. Let's start clean.
- Make sure all firefox windows are closed, including Downloads.
- Open System > Administration > Synaptic Package Manager (You'll have to enter your user password)
- When synaptic appears, type "flash" into the Quick Search field.
- Below that, the list of packages should filer down to stuff related to flash. Items with a green checkbox mean that you have that package installed on your system. Go through the list and right-click on any package related to flash which you have installed and choose "Mark for Complete Removal" This may include flashplugin-installer, flashplugin-nonfree, and swfdec-mozilla.
- Click the "Apply" button in the button bar, and follow the prompts for it to remove those packages.
- You probably don't have to, but restart your computer just in case.
- Go Back into synaptic, type "flash" into the quick search, and right-click on flashplugin-installer. Choose "Mark for Installation"
- Click apply, follow the steps, and when the install is done, close synaptic, open firefox, and see if you're in business...

Thanks Mike Matis, that solved my question.

Unfortunately, through the process of fixing this, I lost the add/remove option from the Application drop-down list. Any idea what I need to do to recover that? Thanks again for your help!

Mike Matis (mmatis) said : #18

- Right-click on the Application menu and select "Edit Menus"
- In window that appears, look in the right-hand column. Towards the bottom there should be the "Add/Remove..." selection. Make sure the checkbox next to it is checked.
- If for some reason it is not there, click the "New Item" button and fill out the box that appears as follows:
Type: Application
Name: Add/Remove...
Command: /usr/bin/gnome-app-install
Comment: Install and remove applications
- Click OK and your new Add/Remove Icon should be in the menu. Click close.
- If that doesn't work, The program "Synaptic," which you used above, performs the same job, though it is less "pretty" and more complex.

I'm happy your Flash issue is fixed. Happy viewing!

Mike Matis (mmatis) said : #19

- Right-click on the Application menu and select "Edit Menus"
- In window that appears, look in the right-hand column. Towards the bottom there should be the "Add/Remove..." selection. Make sure the checkbox next to it is checked.
- If for some reason it is not there, click the "New Item" button and fill out the box that appears as follows:
Type: Application
Name: Add/Remove...
Command: /usr/bin/gnome-app-install
Comment: Install and remove applications
- Click OK and your new Add/Remove Icon should be in the menu. Click close.
- If that doesn't work, The program "Synaptic," which you used above, performs the same job, though it is less "pretty" and more complex.

I'm happy your Flash issue is fixed. Happy viewing!

Mike, all I have to say is I hope there's somebody out there that pays you money to do this kind of stuff! You're 2 for 2 with me. I have a feeling you'll be hearing from me again.

Thanks Again!

Tim

Mike Matis (mmatis) said : #21

I'm just an idealistic volunteer. You're most welcome.

Hold on a sec! Now it appears in the drop down list....but when I try to open it I get this message:

"Failed to execute child process "/usr/bin/gnome-app-install" (No such file or directory)"

Any ideas?

Sorry to keep bugging you.

Tim

Shahar Or (mightyiam) said : #23

You probably have removed gnome-app-install while using synaptic.

Please type 'dpkg -l gnome-app-install' in a terminal and paste the results here.

You were right. I removed gnome. I went through Synaptic, and reinstalled it. Everything works fine now. Thanks again for your help!

Tim