(Firefox) Unstyled <input>, <textarea> and <select> elements have dark background and dark text (how to disable forms.css?)

Asked by A.C. v.d. Berg on 2017-11-15

As the title states, every unstyled <input>, <textarea> and <select> element (as in, no css rules applied) is dark with dark text. Making them very hard to read.
Example: https://imgur.com/a/tfYXV

I've already tried the following things:
1) Changing the Firefox "Colors" settings under Preferences -> Language and Appearance -> Colors.
I've tried every possible setting. (Alway override, never override, high contrast, "Use system colors", custom colors etc.)
But none of those will actually change the input elements.

2) Switch over to a brand new default Firefox profile.
Yielded no changes. None at all.

3) Change the desktop theme to the default. Under System Settings -> Workspace Theme -> Look And Feel to "Breeze" and Desktop Theme to "Air".
Yielded no changes in Firefox.

4) Changing the Firefox theme under Add-ons -> Appearance from "Default" to "Compact Light".
It only changed the colors of the Tab and Toolbar.

5) Disabling the "Ubuntu Modifications" browser extension.
Yielded no changes.

The above screenshot was taken with a default (freshly generated) Firefox profile.
I only have this problem in Firefox and now that I'm writing this I noticed it happens in their Dev-tools too:
https://imgur.com/a/rhnjP
As you can see, the "forms.css" (thankfully) makes the input text bright on this very page. But not on others.
Upon closer inspection I notice that it's also making the input element's background dark. This does work on every page. EDIT: Except if the element has some other css applied of course.
The css resides at resource://gre-resources/forms.css

My question is: How do I disable/remove this css file. I really don't need something messing with every page since it simply doesn't work.
Please feel free to ask anything. I will try anything at this point since I'm totally out of ideas.

Software versions:
Linux Nemesis 4.10.0-38-generic #42-Ubuntu SMP Tue Oct 10 13:24:27 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux
Distributor ID: Ubuntu
Description: Ubuntu 17.04
Release: 17.04
Codename: zesty

Firefox 56.0+build6-0ubuntu0.17.04.2

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
A.C. v.d. Berg
Solved:
2017-11-16
Last query:
2017-11-16
Last reply:
A.C. v.d. Berg (smokey88) said : #1

Update: Had a Firefox update. I'm at version 57.0+build4-0ubuntu0.17.04.5 now.
Still the same problem.

A.C. v.d. Berg (smokey88) said : #2

I've found and solved the issue!
I went to System Settings -> Application Style -> GNOME Application Style (GTK) and set both the GTK2 and GTK3 themes to "Breeze".
Hope this will help others.