Firefox: tries to start but it closes, corrupted ~/.mozilla ?

Asked by ZuCk on 2008-12-10

Bug seen in a MacBook Santa Rosa rev Oct 07. On Ubuntu 8.10 and the kernel 2.6.27-10-generic. After upgrade all distro, firefox tries to open and the taskbar shows "Starting mozilla firefox" but doesn't start. I tried to remove it and install it again but doesn't responses.
I've made a "strace firefox" command and the problem was that in /home/user/.mozilla doesn't have permissions. It creates a folder with mkdir but says "such no file or directory". The problem was resolved with "chmod 777 /home/user/.mozilla"

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
2008-12-11
Last query:
2008-12-11
Last reply:
2008-12-11

This question was originally filed as bug #306941.

Dave Walker (davewalker) said : #1

Converting to a question, although there could be an underlying bug - I think there is some support required here. Please convert back to bug if required.

Please try to clean firefox mozilla profile

Close all opened Firefox and try to delete your Firefox user setting open a terminal from applications → Accessories → Terminal and type:
mv .mozilla .mozilla_old
and restart Firefox.

If you have a lot of bookmarks please export them before move your setting directory, then import them again from saved file into Firefox.
Also take note of your installed Firefox extensions, to reinstall them.

if this works then delete the .mozilla_old directory, from terminal, type:
rm -fr .mozilla_old

hope this helps

ZuCk (fabregas-oriol) said : #3

I've solved the bug, firefox works now and I already did this to move .mozilla but it didn't works. The problem was the permissions. Thanks for support but i just posted the bug if other people has a Macbook (or not), just has the this bug too. Hope this helps, too

sorry for my little english, thanks again

ZuCk (fabregas-oriol) said : #4

Thanks marcobra, that solved my question.