Directory delete problem

Asked by Anup Roy on 2017-02-09

Hi Team,

I am beginner in ubuntu. I face a problem. I was create a user and group under this group I was create a directory. After change my user I was delete that user, but now my that directory I cannot delete it. Show me this: newdirectory2': Operation not permitted
Screenshot: http://prnt.sc/e6mbg4

So please anyone can suggest me to how I delete this directory as soon as possible.

If you have any issue, let me know.

Kind Regards
Anup Roy

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Folkhard Müller
Solved:
2017-02-11
Last query:
2017-02-11
Last reply:
2017-02-09
Best Folkhard Müller (folkhard) said : #1

I do not quiet understand your problem. I guess you are not a native speaker to English, nor am I.
However I try an answer for you:

Become a user which is not restricted (For example the first user you created when installing ubuntu)

As that user:
start a terminal
Inside the terminal enter:

sudo rm -rf /home/{tHE USERNAME YOU WANT TO REMOVE}

You will be asked for the password of the non restricted user.

Beware: rm -rf Name removes everything down the tree! you may remove evrything with rm -rf /. (If you have aprobriate rights.

Anup Roy (anuproy) said : #2

Hi Folkhard,

Hope you are doing well. Yes, I am not a native English speaker and my English is very bad. Anyway, I understand what you said.
First of all, I said I am not deleted my built in user my administrator user is cpo-experts. I deleted my second user which creates this code:

$ sudo adduser abc

Delete user: $ sudo userdel abc

I deleted this abc user not cpo-experts. But now I cannot delete this directory which is named newdirectory2 show in the screenshot in Desktop. It was (newdirectory2) on abc user but I already delete abc user and now I'm administration mode.

My question is how I delete this directory(newdirectory2)?

If you have any issue, just feel free and let me know.

Sincerely,
Anup Roy

Anup Roy (anuproy) said : #3

Hi Folkhard,

I just solved my issue.

Thanks dude,

Anup Roy (anuproy) said : #4

Thanks Folkhard Müller, that solved my question.