associate .m3u files with xmms

Asked by fswat on 2007-03-18

How do I associate .m3u files with XMMS in Firefox?

Everytime I go to a URL that has .m3u audio files and click on them Totem's Video Application comes up instead... I want XMMS to play the .m3u files.

Thank you

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Rthaduthd Anthnhkrc
Solved:
2007-03-18
Last query:
2007-03-18
Last reply:
2007-03-18
JLR (artirj) said : #1

Download a .m3u file and click on Open with. Choose XMMS.
GO to properties and click on Open with and set XMMS as default

fswat (fswat) said : #2

I am still having problems. When I go to the site that has .m3u files Totem still opens and then I get an error message that I don't have the right decoder installed and then I close the error message and the file is populated on my desktop. So I right click on the file and select open with XMMS and then go to properties and set the file to open with XMMS. Then it works but still everytime I go back to the .m3u site the same problem occurs. Totem opens and gives me an error message and dumps the file to my desktop.

Somehow within Firefox's browser there has to be a solution to stop Totem from opening and instead have XMMS open instead of Totem.

Edit -> Preferences -> Content (the tab)

..then in the "File Types" section click Manage. I have no entries for .m3u-files there, so you might want to remove any entry you have. I'm guessing this causes Gnome (instead of Firefox) to handle what to do with the file.

fswat (fswat) said : #4

I solved the problem it was a default issue that was proposd earlier. I just did not make sure the back dot was in the XMMS circle. Instead I shortcut the process by clicking on the word Xmms. In any case the issue is solved.

Thank you everyone. Your help is appreciated.

Frank