Ubunto (VMWARE) won't play AVI's and such

Asked by Zolar1

When I click on an AVI or MPEG or MPG, I download the files to Desktop. This is not the problem.

The problem is when I click on any of the files, I get an error stating no codecs installed.

How do I get my files to play?? I looked in the player and there's no option to even choose to download codecs.

Using the latest version of VMWARE as of January 2006.

And once I get codecs, how do I install them? And will VMWARE 'restore' itself after I put the codecs in?

Question information

English Edit question
Ubuntu firefox Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
sameet (msameet) said :

you can play all the files with VLC media player out of the box!

Revision history for this message
Zolar1 (zolar1) said :

Umm...sorry, but Totem launches and says there are no codecs and that I need to install them.
There is NOOO option to install codecs.
I can't even get rid of Totem either...

And where is this VLC media player? How do I change the default app opening when clicking on a file?

Revision history for this message
magilus (magilus) said :

Just follow this guide: https://wiki.ubuntu.com/RestrictedFormats

It describes how to play lots of formats with Totem.

Revision history for this message
Zolar1 (zolar1) said :

Since I do not know much about Linux or how to do things, I have to let this one go. Too complicated for me to do until I learn more.

I just need it to play what I want without having to do extraneous work.
VMWARE/UBUNTU should have either made a simple quick point and click to get the codecs or preferrably included them in the US Distro.