Firefox crash after Adobe Flash plug-in installation

Asked by Antonio Pérez on 2007-01-01

I just got a new laptop and installed Ubuntu 6.10 on it. The distro includes Firefox version 2.0 (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1) Gecko/20060601 Firefox/2.0 (Ubuntu-edgy))

Browsing the folowing a page under www.uoc.es I'm asked to install Adobe Flash plug-in which I accept. Once installed, Firefox crashes and now just entering www.uoc.es (which worked previously) crashes the browser with following error:

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

** Message: plugin_get_value 1 (1)

** Message: plugin_get_value 2 (2)

The program 'Gecko' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
 (Details: serial 118 error_code 8 request_code 143 minor_code 3)
 (Note to programmers: normally, X errors are reported asynchronously;
  that is, you will receive the error a while after causing it.
  To debug your program, run it with the --sync command line
  option to change this behavior. You can then get a meaningful
  backtrace from your debugger if you break on the gdk_x_error() function.)

I've looked up where to uninstall the plug-in but could not find anything in Firefox preferences or the Ubuntu System Administration tools.

Any clue?

Thanks in advance.

   Antonio

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Antonio Pérez
Solved:
2007-01-03
Last query:
2007-01-03
Last reply:
2007-01-02
Wolf Canis (wolf-canis) said : #1

Hello,
probable in your /etc/X11/xorg.conf is a mistake. Open the file with your preferred editor
(sudo YOUR_EDITOR /etc/X11/xorg.conf), search for the line

 DefaultDepth 16

that is in section Screen, the value 16 is a assumption by me. This line change to

DefaultDepth 24

after that, save the file. Logout and restart the X-server (On login screen press CTRL+ALT+BACKSPACE). Now should the X-server restart and your changes are applied.
Now login and test firefox, it should work.

Good luck Antonio,
                               Mr Canis

PS: Worth case szenario: The X-server doesn't start. Keep cool. Press CTRL+ALT+F1,
your are now on the console. You should see a login prompt. Login and load the file in a
editor again and reverse your changes. Than save the file. Now you can't start the
X-server how described above, because the X-server doesn't run. Now you type on the
prompt

$ sudo /etc/init.d/gdm restart

The X-server should now start up.

Should this happen, I need more details. (~/.xsession-errors, syslog, kern.log, x.org.log)
Not all, only short before the crash happens.

Best Antonio Pérez (apbarrero) said : #2

Thanks Mr Canis,

It certainly solve the problem, though I really don't know why... I mean, the error traces said absolutely nothing about color depth, or did I miss anything here?

Anyway, crash is avoided but when Flash is working I don't get to see any text, so I guess some fonts are missing, but, just for the Flash plug-in???

I'm pretty sure someone would have had the same problem, is it an easy issue to solve or should I read the Adobe Flash Plug-in documentation?

Thanks again.

   Antonio.

Wolf Canis (wolf-canis) said : #3

Hello,
I had this problem a couple of weeks ago on a Toshiba Tecra 8100, but in this case after
switch to colour depth 24 all works fine, no problems with fonts.
Maybe you can post the file section from your xorg.conf and I can compare it with mine and
with that on the Tecra?
To read the documentation is always a good idea, but I think your are right with your
assumption.

Best regards,
                      Mr Canis

Antonio Pérez (apbarrero) said : #4

Hi everybody,

Just for the record, I solved the fonts problem installing the latest (16/01/2007) version (9.0.31.0) of the Adobe Flash Player. All fonts are displayed now.

Thanks for supporting!