where is firefox 29.0.1

Asked by Bobby de Vos on 2014-05-15

Firefox was upgraded to 29.0.1 by the Mozilla team and the release notes said some security fixes were included. I have not seen an update to Firefox 29.0.1 for Ubuntu precise. Does there need to be a firefox 29.0.1 for precise for security, or are the security flaws not present on Ubuntu precise for some reason (such as compiler settings)?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Daniel Letzeisen
Solved:
2014-05-21
Last query:
2014-05-21
Last reply:
2014-05-17

What is the output of :

lsb_release -a; uname -a; apt-cache policy firefox

Thanks

Bobby de Vos (devos-bobby) said : #2

I have two machines

$ lsb_release -a; uname -a; apt-cache policy firefox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise
Linux server1 3.8.0-39-generic #58~precise1-Ubuntu SMP Fri May 2 21:33:17 UTC 2014 i686 i686 i386 GNU/Linux
firefox:
  Installed: 29.0+build1-0ubuntu0.12.04.2
  Candidate: 29.0+build1-0ubuntu0.12.04.2
  Version table:
 *** 29.0+build1-0ubuntu0.12.04.2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ precise-updates/main i386 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main i386 Packages
        100 /var/lib/dpkg/status
     11.0+build1-0ubuntu4 0
        500 http://ca.archive.ubuntu.com/ubuntu/ precise/main i386 Packages

$ lsb_release -a; uname -a; apt-cache policy firefox
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.4 LTS
Release: 12.04
Codename: precise
Linux laptop3 3.5.0-49-generic #74~precise1-Ubuntu SMP Fri May 2 21:32:31 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
firefox:
  Installed: 29.0+build1-0ubuntu0.12.04.2
  Candidate: 29.0+build1-0ubuntu0.12.04.2
  Version table:
 *** 29.0+build1-0ubuntu0.12.04.2 0
        500 http://ca.archive.ubuntu.com/ubuntu/ precise-updates/main amd64 Packages
        500 http://security.ubuntu.com/ubuntu/ precise-security/main amd64 Packages
        100 /var/lib/dpkg/status
     11.0+build1-0ubuntu4 0
        500 http://ca.archive.ubuntu.com/ubuntu/ precise/main amd64 Packages

Thanks!

Security tracker does not list issues fixed in 29.0.1: http://www.mozilla.org/security/known-vulnerabilities/firefox.html

I guess you may have seen the release notes, which are confusing since they also include 29.0 changes. :\
http://www.mozilla.org/en-US/firefox/29.0.1/releasenotes/

I also find it odd that 29.0.1 is not available in Ubuntu yet. Usually, Chris Coulson is on top of that, but maybe it isn't a high priority without security fixes.

Bobby de Vos (devos-bobby) said : #4

Yes, you are correct, I had seen the release notes, but failed to notice how 29.0 changes where still listed on the 29.0.1 page. Thank you for pointing that out. And if there is no security issue, then I personally don't need Chris to produce an update. I have appreciated his quick work in the past on security issues.

Bobby de Vos (devos-bobby) said : #5

Thanks Daniel Letzeisen, that solved my question.