quantal: broken javascript in firefox 16

Asked by Yuri Einullo on 2012-10-22

Hello, guys! I suspect it has something to do with the new webapps feature, because this worked in Firefox 16 on Precise Pangolin, and now it doesn't :( I am trying to add some search engines from this site http://mycroft.mozdev.org and it says "JavaScript must be enabled to install a search plugin". However, JavaSript is enabled in settings and it's a fresh install, so I have no other addon's that could block it...

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Last query:
2012-10-22
Last reply:
2012-10-22
Chris Coulson (chrisccoulson) said : #1

Thanks. Unfortunately, the webapps addon replaces the window.external DOM object with its own object, which removes the ability to install opensearch plugins

Yuri Einullo (oddowl) said : #2

OK, I just copied over XML files from "searchplugins" folder on another install and it seems to have worked (as a workaround of course).

Morten Holmstrup (robotjox) said : #3

@Yuri - could you explain what you did in more detail? I don't have another install

Yuri Einullo (oddowl) said : #4

Morten, I meant to say that I had kept Precise Pangolin alongside, on another partition, so I just mirrored Firefox profiles folder. I think you can also add search engines manually with the help of "Organize Search Engines" plugin (just look it up in Firefox add-ons).

Can you help with this problem?

Provide an answer of your own, or ask Yuri Einullo for more information if necessary.

To post a message you must log in.