Help with Flash 9

Asked by tato97 on 2008-01-02

I'm new to Ubuntu 7.10 and Firefox 2.

Currently I can't use/see a lot of sites that require Flash 9. My son can't use his favorite site Nick.com because nothing displays (other than the adds).

I've tried for hours to install/remove/re-install Flash 9 with no results. I followed the instructions in posting 19962 but it did not solve the problem. My system still reports that Flash 8 is installed as follows:

Shockwave Flash

    File name: libgnashplugin.so
    Shockwave Flash 8.0 r99. Gnash 0.8.1, the GNU Flash Player. Copyright © 2006 Free Software Foundation, Inc.
    Gnash comes with NO WARRANTY, to the extent permitted by law. You may redistribute copies of Gnash under the terms of the GNU General Public License. For more information about Gnash, see http://www.gnu.org/software/gnash. Compatible Shockwave Flash 8.0 r99.

MIME Type Description Suffixes Enabled
application/x-shockwave-flash Shockwave Flash swf Yes

If I check with Adobe Flash test it reports that Flash ver 8 is installed. Problem is most sites now have update their Flash to ver 9. Can't use YouTube, Yahoo IM, Toyota, Nick, etc.

I read somewhere there's a bug with Flash 9 r48 and that it's solved by r115...but I can't understand what/how to resolve the issue and update my system. The system's Synaptics points to the r48 package. I tried downloading the rpm, unpacking and installing (all very new to me) and it made a .firefox/plugin directory in my home but the plugin folder is empty.

Sorry for the long post but I'm trying to provide as much info as possible.

Any help is appreciated!

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
tato97
Solved:
2008-01-02
Last query:
2008-01-02
Last reply:
2008-01-02
Jim Hutchinson (jphutch) said : #1

Try the option in this thread

http://ubuntuforums.org/showthread.php?t=636397

The updated part is in blue and has links to download. This is what I used and it's working fine.

Jim Hutchinson (jphutch) said : #2

Oh, one more thing. It seems the new version isn't working with some sites including nick.com. Sorry.

tato97 (ta931115) said : #3

Installed the package as per instructions on ubuntuforums. It Installed w/o errors but yet when I check Firefox with about:plugins or if I run the Adobe Flash test it still reports ver 8 r99 is installed. Same problems with all sites listed in my original posting, none work.

I checked in my home under .firefox/plugins also in usr/lib/firefox(and mozilla)/plugins but don't see anything installed there other than a file named flashplugin-alternative.so in the last two directories.

So don't know where is the current ver. installed and if it can/should be removed prior to running the ver 9 r115 installation.

Jim Hutchinson (jphutch) said : #4

Did you uninstall the original version of flash before installing the new one? If not, open Synaptic and remove flash. Then install the one from the ubuntu forums.

tato97 (ta931115) said : #5

I had tried several times before to uninstall Flash ver 8 r99 from Synaptic to no avail but Ala! when I did a search this time both Flash ver were found in Synaptic ver 8 r99 and ver 9 r115. I did an unistall on ver 8 r99 and wala, everything is working now albeit a little slow on Nick but it works!

The nick.com site works much better on my Vista machine with Firefox and same Flash ver 9 r115 but it also work on my ubuntu machine.

THANKS!!!