Adobe flash player not working

Asked by Randy Williams on 2007-12-08

I installed the latest Ubuntu 8.?? release. When I go to my website with Video, the website indicates that I need to install Adobe Flash Player, but it is already installed. I just recently started using Linux, so I'm still learning how to use it, but as a fairly techy person I was trying to fix friends dismounted Vista and decided to try Ubuntu.

If I can get this flash player to work I think I have a pretty solid OS to get my friend to keep it.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
Dara Adib
Solved:
2007-12-09
Last query:
2007-12-09
Last reply:
2007-12-08
Ralph Janke (txwikinger) said : #1

Thanks for the question.

You should also install the package "mozilla-acroread" which will install the
Adobe Reader - mozilla/konqueror plugin.

I hope this helps.

Best Dara Adib (daradib) said : #2

I don't believe Ralph Janke's answer is correct. This is about Adobe Flash Player, not Adobe (Acrobat) Reader.

This is not your fault. This is a very recent bug, caused by Adobe's update of Flash 9.0 update 3 (9.0.115.0) codename "Moviestar" on December 4th.

http://www.adobe.com/aboutadobe/pressroom/pressreleases/200712/120407adobemoviestar.html

This caused Ubuntu to not install the flash plugin, detecting a change in the flash plugin installer file (via MD5 checksums). See bug 173890. This bug has been fixed in the next release of Ubuntu (Hardy 8.04) and it should soon come as an update to Ubuntu 7.10.

If you want an immediate fix, do the following.

Using Synaptic Package Manager, remove the package flashplugin-nonfree. For more information on how to do this, see the Ubuntu documentation here: https://help.ubuntu.com/7.10/add-applications/C/advanced.html#synaptic

Alternatively, you can run this command in the Terminal (Applications -> Accessories -> Terminal): sudo apt-get remove flashplugin-nonfree

Then just download this package (32-bit only) and install it (it is identical to the current package in the next release of Ubuntu, Hardy 8.04): http://launchpadlibrarian.net/10761023/flashplugin-nonfree_9.0.115.0ubuntu2_i386.deb

If you have 64-bit Ubuntu (not likely or recommended for a person new to Ubuntu), you currently need to build a binary package from this source package: http://bugs.launchpad.net/ubuntu/+source/flashplugin-nonfree/9.0.115.0ubuntu2

Randy Williams (srw3) said : #3

Thanks Cyrus Jones, that solved my question.

Dara Adib (daradib) said : #4

Cheers. Happy Ubuntuing!

Ebon Elza (ebonelza) said : #5

Ditto, Cyrus Jones' solution worked for me. Thanks!

Dara Adib (daradib) said : #6

In case someone else sees this, I recommend using the instructions here: http://ubuntuforums.org/showthread.php?t=636397

Mr. Cyrus Jones, the flashplayer on my computer also is not working. My system is Ubuntu 7.10 on a 32 bit notebook computer (Athec). I have removed the flashplugin-nonfree in Synaptics first before downloading and installed the flashplayer from the page you gave in the text box above. That went fine. So the flashplugin-nonfree is back in my Synaptics list, but the problem has not been solved. What to do?

Dara Adib (daradib) said : #8

Please remove flashplugin-nonfree in Synaptic first (again).

Download this file: http://ubuntuforums.org/attachment.php?attachmentid=53648
Note: You need to be logged into Ubuntu Forums, this is URL for an attachment on the thread http://ubuntuforums.org/showthread.php?t=636397

Assuming you save to Desktop, do the following commands in Terminal (Applications -> Terminal) one at a time:

cd Desktop
sudo dpkg -i flashplugin-nonfree_9.0.115.0ubuntu0.7.10_i386.deb
sudo apt-get install -f

Then open your browser (I assume it is Mozilla Firefox, if it is any different please say so) and it should work.

Keep the terminal open the whole time so you can copy-paste the output here if it still does not work.

Mr. Cyrus Jones, I have removed the flashplugin first as you told me and installed the new flashplugin (32-bit only) as said above. I have checked that the plugin was removed and checked that the new plugin was installed, but the plugin is still not working. As I have installed Ubuntu 7.10 from CD and not online, could it be that I should install something from Synaptics as well?

Dara Adib (daradib) said : #10

In Firefox, got to the address about:plugins
What references are there to flash?

Also, please do the steps I said in my last comment in the Terminal (Applications -> Terminal). Keep the terminal window open, and copy and paste all of the text in the Terminal window after entering the commands here.

Dear mr.Jones,
Where in Firefox can I find the address about: plugins?

After clicking your link, I got a window with this:

Adobe Flash Player plugin installer
This package will download the Flash Player from Adobe.
It is a Netscape/Mozilla type plugin.
Any browser based on Netscape or Mozilla can use the Flash plugin.
This package currently supports the following browsers: Mozilla, Mozilla-Firefox, Firefox, Iceweasel, and Iceape.
Also Galeon and Epiphany can use the Flash plugin.
Konqueror can also use the Flash plugin if konqueror-nsplugins is installed.
WARNING: Installing this Ubuntu package causes the Adobe flash plugin to be downloaded from www.adobe.com.
The distribution license of the Adobe flash plugin is available at www.adobe.com.
Installing this Ubuntu package implies that you have accepted the terms of that license.
Homepage: http://wiki.ubuntu.com/FlashPlayer9

After clicking the install button the flasplayer was installed, but still not working.

For everyone who kept thinking about my flash problem. It is solved. The Gnash movieplayer stood in the way. So I removed that player and that was it. The Flashplayer is working fine, thank you. Problem solved. End of story.

merseysoft (myles-scott) said : #13

Cheers Cyrus!

Dara Adib (daradib) said : #14

Good luck.

Luxman (k-luxman) said : #15

Hi,

I tried to install flash plugin. it didn't work for me.
this is the message I got it in Terminal window..
ubuntu@ubuntu-desktop:~/Desktop$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Some one please help me on this..

Thanks in Advance

-Laxman

@Luxman

Please don't append a new question on a marked as solved question.
Please make new question from here: https://answers.launchpad.net/ubuntu/+addquestion
you will get better chance to get right answer on a fresh tagged "open" question.
Solved question are usually not read from answering people.

Thank you