firefox slow under 7.10

Asked by jack mahoney on 2007-11-04

Hi,
   I upgraded from 7.04 to 7.10, and since then, firefox has slowed waaay down. I get the message "looking up... (website)" for about 45 secs before a page loads. Any suggestions? Btw, I have a dual-boot system and XP is fine.

Thanks,

jack

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Jan-Philipp Litza (jplitza) said :
#1

Does the problem occur elsewhere as well? I suppose the problem is DNS related, maybe because Gutsy is the first release which uses avahi by default. Please tell us the contents of /etc/resolv.conf and the output of `dig (address)` (for example `dig google.com`) and if it took as long as in Firefox.

Revision history for this message
jack mahoney (jm8094) said :
#2

Hi, I found the instructions below, which fixed the internet response problem. Can someone tell me how to find my device name (mine is not "Eth0", since an error msg was returned on this command:
      $ sudo ifdown eth0 && sudo ifup eth0

(I want to be sure the new DNS # stays permanent.)

Btw, thanks for the quick response.

jack

1. Open a terminal window and type the following.

    $ sudo network-admin

Note: Root access is required for this step.

2. Change to the DNS tab and enter the following two addresses in the top of the first field labeled DNS Servers.

    208.67.222.222
    208.67.220.220

To avoid having your settings get revoked after reboots, or after periods of inactivity, do this:

    $ sudo cp /etc/resolv.conf /etc/resolv.conf.auto
    $ sudo gedit /etc/dhcp3/dhclient.conf
    # append the following line to the document
    prepend domain-name-servers 208.67.222.222,208.67.220.220;
    # save and exit
    $ sudo ifdown eth0 && sudo ifup eth0

You may be required to change eth0 to your own network device's name if it uses a non-standard name.

> -----Original Message-----
> From: <email address hidden>
> Sent: Sun, 04 Nov 2007 12:40:49 -0000
> To: <email address hidden>
> Subject: [Question #17008]: firefox slow under 7.10
>
> New question #17008 on firefox in ubuntu:
> https://answers.launchpad.net/ubuntu/+source/firefox/+question/17008
>
> Hi,
> I upgraded from 7.04 to 7.10, and since then, firefox has slowed waaay
> down. I get the message "looking up... (website)" for about 45 secs
> before a page loads. Any suggestions? Btw, I have a dual-boot system
> and XP is fine.
>
> Thanks,
>
> jack
>
> --
> You received this question notification because you are a direct
> subscriber of the question.

Revision history for this message
Jan-Philipp Litza (jplitza) said :
#3

`ifconfig` will give you a list of all currently active interfaces, `ifconfig -a` a list of all recognized interfaces. Which of them the right one is depends on your connect: wlan0, wifi0 or ath0 (or maybe eth1) could be for wireless network, ppp0 for a dialup connection, eth0 for wired ethernet and PPPoE.

Can you help with this problem?

Provide an answer of your own, or ask jack mahoney for more information if necessary.

To post a message you must log in.