firefox does not start on ubuntu 10.10.

Asked by akshay shah on 2010-11-26

I am using Ubuntu 10.10. for some days firefox worked fine. once while browsing it was not closed and i restarted the system in order to re-establish the connection. after this fire fox just did not start it kept prompting to close an already running session even after several restarts.
the error message was -

"Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Solved by:
akshay shah
Solved:
2010-11-27
Last query:
2010-11-27
Last reply:
2010-11-27
Willem Hobers (whobers) said : #1

Hi, sorry to hear about your problems.

An already running instance of firefox seems to be preventing firefox to start up fully.
You restarted the system, you say. That should normally help to get rid of any running processes.
But I understand that in this case the restart did not help.

After you got the "already running" message you might try to run "system monitor":

Main Menu: System --> Administration --> System Monitor.

In the tab Processes you see the running processes.
In your case you should be seeing a process called Firefox.

Right click on that process en choose End Process.

Then the process should disappear from the list of running processes.
Close System Monitor.

Then restart Firefox.

I would expect Firefox to fully start after this.
If not, I think your firefox install may be broken.

Please try the above and report what happens.

akshay shah (axe-s86) said : #2

thanx willem for the quick response. i forgot to mention the ways i tried to resolve the issue. i did not see any process running named firefox fter that crash and thereafter never in the system monitor.

secondly i tried to remove and reinstall firefox from ubuntu software centre( since i was not aware of the dependant packges to be removed through synaptic pacakge manager). even this didn't help. after reinstalling also the same pop-up message prompts the same thing.

Open a terminal and type

firefox

and then

firefox -safe-mode

report message and errors here...

akshay shah (axe-s86) said : #4

same error message both the times.
 "Firefox is already running, but is not responding. To open a new window, you must first close the existing Firefox process, or restart your system."

Akshay,
Try reinstalling Firefox

sudo apt-get purge -y firefox
sudo apt-get autoremove
sudo apt-get install firefox

I hope it is helpful

Regards,
Ricardo

akshay shah (axe-s86) said : #6

well, thanx for suggestion. just now i tried that way but that too is not helping. this time the pop-up message is the same but the terminal error now has changed. after i typed firefox and pressed enter the terminal lookks like this

"akshay@akshay-Compaq-420:~$ firefox
shm_open() failed: Permission denied
"

Jonathan Mast (onlineamateur) said : #7

What do get if you type
firefox -profilemanager

akshay shah (axe-s86) said : #8

thanks jonathan. that was a helpful hint!
after i typed "firefox -profilemanager", i got a profile manager window where there was a profile named "default".
I deleted that one and created the new profile saved it and closed it. and bingo! firefox started!