Firefox won't go online, error message "Offline Mode"

Asked by Nicole Chung on 2010-11-08

Hi guys,

When I log into Ubuntu, I'm trying to get online but won't let me, it keeps saying "Offline Mode" even though I have refreshed the webpage and still won't get me online. I have checked the LAN (the wire) whether it was loosen or not but wasn't.

Is there a way to fix the issue I have here?

Thanks

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox Edit question
Assignee:
No assignee Edit question
Last query:
2010-11-08
Last reply:
2010-11-08

I guess you are using (crappy) firefox. Firefox has a MASSIVE hangup with network manager whereby if the wireless isn't connected it moans. If you install another browser, is it ok?

If it isn't I know exactly what it is (DNS) otherwise if you still want to use firefox there is an about:config hack to make it not care.

Nicole Chung (chungnicole) said : #2

Whats the meaning of "(crappy) firefox"? About the DNS, do I have to assign that from the router?

In short, I hate firefox. You should get dns from the router but sometimes it needs to be manually deined for whatever reason. Things aren't working so we need to take extra steps.

Nicole Chung (chungnicole) said : #4

Do you think the network (router) blocked firefox from accessing to the Internet?

No its the firefox hangup. Have you tried the other browser yet? The router will not block the app if its a generic home grade router. Also check the browser isn't in offline mode under the file menu.

Nicole Chung (chungnicole) said : #6

I have tried unchecking the offline mode but still doesn't work. What else can I do?

mycae (mycae) said : #7

The problem is probably that NetworkManager is telling firefox that one network card is not in use, and thus the computer is "offline". Its a bad state of affairs, but until somone fixes it. you can do this:

load firefox
in the address bar type "about:config"

accept the warnings, then type "Toolkit.networkmanager.disable" in the bar. Click (double click?) the value to set it to false.

http://kb.mozillazine.org/Toolkit.networkmanager.disable

Did you try a different browser?

mycae (mycae) said : #9

My apologies, the correct value is "true" not "false"

Nicole Chung (chungnicole) said : #10

When I typed into the address bar: about:config it led me to "Here be dragons" and then it has got a button saying "I'll be careful, I promise"

What do I do next?

Nicole Chung (chungnicole) said : #11

How do I install a different web browser?

mycae (mycae) said : #12

>What do I do next?

Once you click on the button labelled "ill be careful", a new window should appear. There is a text box labelled filter. In that box type "Toolkit.networkmanager.disable" (or cut and paste, whatever is easiest).

This should leave exactly one option below it, with the name "Toolkit.networkmanager.disable". If the value is "false", double click it to set it to true. Once you do this, select file -> work offline to go back online.

If this does not solve the problem, then something else is at fault.

Nicole Chung (chungnicole) said : #13

I have just tried the above you have mentioned but still didn't solve my issue. What else could it be the fault?

mycae (mycae) said : #14

I am unsure. You can try a different browser, as suggested above. Use the software center to install chromium, ephiphany or konqueror.

mycae (mycae) said : #15

Another option is to try installing this extention under firefox:
https://addons.mozilla.org/en-US/firefox/addon/13152/

Nicole Chung (chungnicole) said : #16

Are you sure those are not games? Those 3 that I just found is games.

Nicole Chung (chungnicole) said : #17

At the moment, I am using windows to communicate with you. Firefox won't get me online so I won't be able to download.

mycae (mycae) said : #18

Sorry, there is also a game called chromium. The browser is "chromium-browser".

peter b (b1pete) said : #19

re ....'How do I install a different web browser?'....

take a look at

https://wiki.edubuntu.org/IceCat

see if this browser helps.

sudo add-apt-repository ppa:chromium-daily/ppa; sudo apt-get update; sudo apt-get -y install chromium-browser

or in firefox access the usual about:config page
make a boolean item named: browser.offline
set it to false
Then make a new boolean value named: toolkit.networkmanager.disable
set it to false
restart the browser

Can you help with this problem?

Provide an answer of your own, or ask Nicole Chung for more information if necessary.

To post a message you must log in.