Firefox Bus Error

Asked by Rick Simnett

When I start Firefox on Ubuntu 7.04 it takes me directly to my homepage. However, when I try to browse to a link on the homepage, or I manually type in a new url to go to, firefox crashes unexpectedly. I ran firefox from the command line to get the output and see what the issue was (I had recently installed a Real Rhapsody plugin which turned out to be incompatible, it has been removed now), and I got this:

rick@rick-desktop:~$ firefox
Bus error (core dumped)

I then reran firefox from the command prompt in safemode and got the same error:

rick@rick-desktop:~$ firefox -safe-mode
Bus error (core dumped)

I have completely removed firefox, and reinstalled it to see if that would correct the issue, and no dice.

Anyone have any ideas of how to fix this? I am using opera now, and its not cutting it.


Question information

English Edit question
Ubuntu firefox Edit question
No assignee Edit question
Solved by:
Terence Simpson
Last query:
Last reply:
Revision history for this message
Best Terence Simpson (tsimpson) said :

Sounds like something from that plugin wasn't removed properly, try moving the ~/.mozilla/firefox/ directory somewhere so it's recreated when firefox starts. If that works then you can at least get your bookmarks back by copying the old ~/.mozilla/firefox/(some random stuff).default/bookmarks.html to the new directory.

Revision history for this message
Rick Simnett (sinfotech) said :

Looks like that fixed it. I guess I should go to Real and tell them their plugin messes up firefox 2 on linux.