Firefox isn't working after install with Ubuntuzilla and then complete removal of both along with cleaning profile, executables etc. How to install fresh from Ubuntu repository

Asked by amar on 2010-01-16

To use Thunderbird's latest version I installed Ubuntuzilla. But later I decided to with Ubuntu releases of Firefox and Thunderbird as the name, icons were changed to something I didn't like. I removed Thunderbird. But in case of Firefox, it was in /opt after Ubuntuzilla install with disabled "check updates". It was showing 3.5.6 where 3.5.7 is released. So removed Ubuntuzilla but update still didn't work. I checked source list and removed repos for Ubuntuzilla and Mozilla-Daily ppa (repo) so that only Ubuntu updates will show in Synaptic. Which is mentioned as: (I think this is 3.5.7):

"firefox-3.5 3.5.7+nobinonly-0ubuntu0.9.10.1 safe and easy bro.."

Update still didn't work (not even with system update).
Then tried a fresh Firefox install from repo and so removed /opt/firefox and also in other places. Even, "firefox" and "firefox-3.5" executables from /usr/bin/ and some files from other places. Cleaned my Firefox profile in ~/.mozilla, I have backed up my profile and settings. Installed firefox from the repo and it's not working. May be because links were symlinked to the one in /opt/firefox/ and moreover I have removed "executables", I am not sure.

How can I go back to original Firefox that came with my Ubuntu Live-CD? Cleaning the mess my stupid attempt might have created. Of course with the latest version available and also the updates should work with Ubuntu updates.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Solved by:
amar
Solved:
Last query:
Last reply:
Revision history for this message
amar (amarendra) said :
#1

Well, I think I solved it. Went to "Synaptic>World Wide Web" and installed latest Firefox available and created the required executables. Then went to "System>Preference>Main Menu> Internet>Firefox" and clicked on "Property" and browsed to "/usr/bin/firefox-3.5" command. And then it's working.
Added Panel shortcut after it.

Revision history for this message
Tom (tom6) said :
#2

Superb :))
I was going to suggest using "Fix broken packages" from Synaptics "Edit" menu or from the boot menu's "recovery mode" but i wasnt certain they would work
Nicely fixed and thanks fro posting the answer :)
Regards from
Tom :)