Firefox doesn't know how to open this address, because the protocol (smb) isn't associated with any program.

Asked by Gary Dean on 2010-01-10

i am wanting to use Firefox to connect to my smb shares. However, i keep getting this error message:

Firefox doesn't know how to open this address, because the protocol (smb) isn't associated with any program.

My client configuration is as follows:

Mozilla/5.0 (X11; U; Linux x86_64; en-GB; rv:1.9.1.8pre) Gecko/20100106 Ubuntu/9.10 (karmic) Shiretoko/3.5.8pre

I tried the instructions below to try and fix the problem with no success:

From http://www.cabo.dk/support-en/tips-and-tricks/how-to-connect-networks-shares-from-firefox-and-safari/view?set_language=en

Linux with Firefox
In order to connect to a network share directly from you browser under Linux, you must configure Firefox to handle URL's starting with "smb://". This is done by typing "about:config" in the address line and hitting return. After that you must right-click the list of settings and choose "New -> Boolean" as shown below.

As name you must type: "network.protocol-handler.external.smb" with a value of "true".
After that you must do the same thing over again, but this time choose "New -> String", type the name: "network.protocol-handler.app.smb" with a value of the path to the application you wish to use for browsing network shares. If you use KDE, this will typically be "/usr/bin/konqueror".

I hope this is sufficient detail for someone to give me a solution to this issue.

Regards.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Solved by:
Gary Dean
Solved:
Last query:
Last reply:
Revision history for this message
Sam_ (and-sam) said :
#1

> isn't associated with any program.
Maybe Samba is missing.
https://help.ubuntu.com/community/Samba
http://en.wikipedia.org/wiki/Server_Message_Block

Revision history for this message
Gary Dean (garydean) said :
#2

samba is installed.

Revision history for this message
David Jones (dj) said :
#3

Linux with Firefox
In order to connect to a network share directly from you browser under Linux, you must configure Firefox to handle URL's starting with "smb://". This is done by typing "about:config" in the address line and hitting return. After that you must right-click the list of settings and choose "New -> Boolean" as shown below.

As name you must type: "network.protocol-handler.external.smb" with a value of "true".
After that you must do the same thing over again, but this time choose "New -> String", type the name: "network.protocol-handler.app.smb" with a value of the path to the application you wish to use for browsing network shares. If you use KDE, this will typically be "/usr/bin/konqueror".

David
in TN

Revision history for this message
Gary Dean (garydean) said :
#4

that's exactly what i did. read original message.

Revision history for this message
Gary Dean (garydean) said :
#5

Solution to this problem can be found here:

http://www.linuxquestions.org/questions/linux-general-1/firefox-smb-woes-...-any-ideas-781219/

thanks to GrapefruiTgirl / Sasha and others on linuxquestions.org for their persistence!