How to restore supported Firefox version

Asked by Ken on 2009-12-23

When investigating Ubuntu tweak I installed Shiretoko 3.5.7. I realise this a development version but although it seems to work fine I would like to get back to a stable release. I haven't experienced many problems except that some sites do not recognise the browser as Firefox and keep telling me it's unsupported.

The main problem is when trying to access Windoz Live Sky Drive (I know, boo hiss but it does give 25GB storage :S). the following error message is displayed

XML Parsing Error: not well-formed
Location: http://cid-068d036531a456d7.skydrive.live.com/summary.aspx?sa=185613436
Line Number 46, Column 184: <div id="m_wh"><script type="text/javascript">/* Copyright (C) 2009 Microsoft Corporation */function $c_TreatTile(a,e){a.style.display=e;var d=a.width,c=a.height,b=19;if(d>=c||c<b)a.height=b;if(d<c||d<b)a.width=b}</script>
---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------^

I am assuming this is not a problem with their site for no other reason than I have never had trouble before. how can I get back to FF 3.5.6 or whichever version ships with Karmic?

Any help will be gratefully received

Ken

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:
Revision history for this message
Ken (kengraham-live) said :
#1

addendum; I have successfully access the site using Opera 10.10 and google Chrome 4.0.249.43

Revision history for this message
Mathilda Young (gtrsdk) said :
#2

Ok I see.... I just installed a nightly version of firefox codenamed Gran Paradiso and I get the same problem. I think you are getting the error because the website can see that it isn't an official version of firefox. You should visit : http://www.mozilla.com/en-US/products/download.html?product=firefox-3.5.6&os=linux&lang=en-US

I have found a way to make it think it is Internet Explorer to let you in and not get the error, but it may not be as reliable as just installing the firefox from the link above. It is an add-on for firefox. The add-on is called "User Agent Switcher" but it probably won't work on your nightly version of firefox unless you have an addon called "Nightly Tester Tools". I have a link for user agent switcher here: https://addons.mozilla.org/en-US/firefox/addon/59
The link to download Nightly tester tools: https://addons.mozilla.org/en-US/firefox/addon/6543

Can you help with this problem?

Provide an answer of your own, or ask Ken for more information if necessary.

To post a message you must log in.