No internet traffic

Asked by Kevin Quinlan on 2009-12-12

I have loaded up Ubuntu 9.10 on a separate hard disk and tried to connect to the Internet through Firefox. The eth0 connection to my modem/router appears to be working OK since I call using its IP address and receive the log on page. On selecting a web site website I get the visual signs that something is happening, lights flashing on the modem/router but after a short time, the system times out. The Firefox error is as follows:

Error: uncaught exception: [Exception... "Component returned failure code: 0x80040111 (NS_ERROR_NOT_AVAILABLE) [nsIXMLHttpRequest.status]" nsresult: "0x80040111 (NS_ERROR_NOT_AVAILABLE)" location: "JS frame :: chrome://ubufox/content/startpage.html :: anonymous :: line 51" data: no]

I have'nt start to tinker yet so it is a virgin installation.

Kind regard

Kevin

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
Last query:
Last reply:
Revision history for this message
actionparsnip (andrew-woodhead666) said :
#1

run:

gksudo gedit /etc/resolv.conf

add these lines:

nameserver 8.8.8.8
nameserver 8.8.4.4

Save the file, close gedit then run:

sudo /etc/init.d/networking restart

Then attempt to browse the web.

Revision history for this message
Kevin Quinlan (kevin-quinlan) said :
#2

Apologies for not responding sooner, but swapping disks and running tests takes a bit of time.

The response solves the problem in part in that it allows me to access the Internet however if I loose or cycle the connection I have to re-do the procedure.
The network manager insists on using the IP address for my modem/router (same as 9.04). What I find puzzling is that I compare the file values with 9.04 (network connection), which works hence this message, and they all appear to be the same.

I am still puzzled?

Revision history for this message
actionparsnip (andrew-woodhead666) said :
#3

you can add the IPs to network manager's config. Personally I don't use it but know it can be added. This wil then always populate the file with good things

Revision history for this message
Kevin Quinlan (kevin-quinlan) said :
#4

I have put 9.10 back to it original state. I then tried to access the Internet and as expected was unable to receive data. I have had a little play with the network tools (System, Administration, Network Tools) the Ping results stated 100%, Traceroute provided the path to ubuntu.com.

It is as if the light is on but nobody is home.

What method do you use to access the Internet that is different from using the network manager? Please detail.

Revision history for this message
Best actionparsnip (andrew-woodhead666) said :
#5

Could try installing wicd from the install CD. May have more success than network manager

Revision history for this message
Kevin Quinlan (kevin-quinlan) said :
#6

Thanks actionparsnip, that solved my question.