"right click" to "open in new tab" not working with firefox 3.5.5 in ubuntu 9.1

Asked by dacostab on 2009-11-30

I am totally new to Ubuntu; been a Windows user all my life, but just getting tired of unkept promises - "Windows 7 improvements"... LOL. Anyway, I have Ubuntu 9.1 loaded, Firefox 3.5.5 installed with some add-ons. I've however noticed that nothing happens when I right-click on a link... no "Open in New Tab"; the "hand" comes up but no response. I have to get this fixed and am hoping that someone out there can help me, please.

DaC

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu firefox-3.5 Edit question
Assignee:
No assignee Edit question
Solved by:
marcobra (Marco Braida)
Solved:
Last query:
Last reply:
Revision history for this message
Best marcobra (Marco Braida) (marcobra) said :
#1

Clean firefox mozilla profile

Close all opened Firefox and try to delete your Firefox user setting open a terminal from applications → Accessories → Terminal and type:
mv .mozilla .mozilla_old
and restart Firefox.

If you have a lot of bookmarks please export them before move your setting directory, then import them again from saved file into Firefox.
Also take note of your installed Firefox extensions, to reinstall them.

if this works then delete the .mozilla_old directory, from terminal, type:
rm -fr .mozilla_old

hope this helps

Revision history for this message
Ryan Dwyer (ryandwyer) said :
#2

This is unlikely, but it's also possible the page you're on has some javascript which disables the right click menu.

I prefer to middle-click/wheel-click on links to open them in new tabs anyway. Try that.

Revision history for this message
dacostab (dacosta-bayley) said :
#3

Thanks marcobra (Marco Braida), that solved my question.

Revision history for this message
dacostab (dacosta-bayley) said :
#4

Thanks Marco! Sorry for the delay in responding; but being new to the forum, I couldn't find my post in order to respond. I guess that I had an invalid add-on that I imported from another platform - right-click works fine now after I purged my profile.

Ryan, I don't have a middle-click/wheel-click on my laptop. Thanks anyway.