browsers do not function after upgrade to Ubuntu 9.10

Asked by paul garavaglia

dell laptop, dual boot, winxp & ubuntu 9.10, firefox working ok in xp, firefox partially working in ubuntu after upgrade to 9.10, can reach these web sites:;; Cannot reach these websites:;;;; These web sites try to load but never finish:; The web sites I have listed are a random sample from my bookmarks just to give you an idea of the erratic nature of the problem. Have tried reinstalling firefox. Also installed Midori and Arora browsers which produced the same results using the above set of web sites. Problem occurs whether using wireless or ethernet connection. Connection to web via DSL. No reason to believe the connection is bad. Am using my desktop PC with firefox installed on winXP to send you this report.

Question information

English Edit question
Ubuntu firefox-3.5 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Brian Murray (brian-murray) said :

Thank you for taking the time to report this issue and helping to make Ubuntu better. Examining the information you have given us, this does not appear to be a bug report so we are closing it and converting it to a question in the support tracker. We appreciate the difficulties you are facing, but it would make more sense to raise problems you are having in the support tracker at if you are uncertain if they are bugs. For help on reporting bugs, see

Revision history for this message
Best wojox (wojox) said :

1. Type about:config in the address bar, press Enter.
2. Find network.dns.disableIPv6 in the list.
3. Right-click -> Toggle.
4. Restart your Mozilla application and try again.

Revision history for this message
paul garavaglia (paulgaravaglia) said :

Thank you, that did solve the problem.
Curious, what is it about IPv6 that Firefox running under Ubuntu 9.10 doesn't like?

Revision history for this message
paul garavaglia (paulgaravaglia) said :

Just want to add that the Arora and Midori browsers still can not reach the bulk of my favourite web pages. Although I don't need to use those two browsers, I have to think that the problem with Firefox lies within the Ubuntu 9.10 OS not within the browser. For the benefit of other users, is there any known work around for Arora or Midori?

Revision history for this message
wojox (wojox) said :

You can turn off ipv6 system wide by editing your grub file.

In the terminal:

gksudo gedit /etc/default/grub

Look for:

GRUB_CMDLINE_LINUX_DEFAULT="ipv6.disable=1 quiet splash
and add the ipv6,disable=1


sudo update-grub

Restart your computer for the effects to take place

Revision history for this message
paul garavaglia (paulgaravaglia) said :

Thank you for getting back. I stumbled onto the fix you mention when searching for "ipv6 disable." Then discovered that /etc/default/grub does not exist on my machine because I had upgraded from jaunty to karmic, but using the jaunty method for disabling ipv6 worked. And, I also learned that my old DSL router is probably the real culprit because it doesn't know ipv6 exists!
Again, thanks for tipping me off to ipv6. I'm not a newbie, but I'm not the sharpest tack in the box, so it takes me a little bit to sort things out.