Firefox profile disabled during first Karmic boot

Asked by John2

Hi all,

After installing Ubuntu 9.10 64bit edition, I can see an error message related to Firefox during the first reboot.

It basically indicates that the Firefox profile was disabled because of a problem in Xulrunner.

I am afraid that I am not so Linux-savvy to know what that means.

However, I cannot create any connection to the Internet.

Any insight on the meaning of the problem, whether the profile and the connection problems are any related and on what I could try to solve the situation would be appreciated.

Thank you in advance.

Question information

English Edit question
Ubuntu firefox-3.5 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Can you ping test? Firefox may be down but that doesnt mean other apps can't acces the web.


ping -c 4

return replies?

if so you can run:

sudo apt-get --purge remove firefox*; sudo apt-get --purge autoremove; sudo apt-get clean; sudo apt-get install firefox-3.5

and you will reinstall firefox

If that fails then try:

mv ~/.mozilla ~/.mozilla_old

then rerun firefox. If this works you have 2 choices:
1. rename back (rm -rf ~/.mozilla; mv ~/.mozilla_old ~/.mozilla) and attempt to troubleshoot the faulty profile (hard)


2. Stick with the new profile and rebuild (you can import favorites from the old profile) with new saved password (if you use them) and skins / plugins / whatever (easy)

Revision history for this message
John2 (humright2) said :

Thanks actionparsnip, that solved my question.

Revision history for this message
actionparsnip (andrew-woodhead666) said :

Which bit fixed it?

Revision history for this message
John2 (humright2) said :

Reinstalling Firefox worked. I had made a backup of bookmarks and I did not have passwords, so restoring was smooth.

Thanks again.