I get an error when I click on the web browser

Asked by William Warner on 2011-01-02

"Could not launch menu item abrowser, file or directory does not exist" How do I fix this? I'm not a big linux geek, so I need step by step instructions. Thank you.

Question information

English Edit question
Ubuntu firefox-3.5 Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:

If you press ALT+F2 and type your browser's name and hit enter, does it run?

Baljeet Singh (baljeetsingh) said : #2

you can update your browser by going to Applications->software manager and click firefox and update....
if firefox does not there then search firefox and click ok, this will install fresh new copy of firefox on your system in ubuntu.........

William Warner (bill-warner7) said : #3

Hi All,

ALT-F2 and it does not run.

I have no "software mgr" in my applications menu. Firefox will run if I open a terminal window and type firefox, but come on there should be a way to fix this issue.

Press CTRL+ALT+T to run a terminal then run:

sudo apt-get update; sudo apt-get --reinstall install firefox software-center

If the menu item is still bad after execution, run:


And edit the command ran by the menu item to be:


Should be ok

William Warner (bill-warner7) said : #5

Thanks actionparsnip, that solved my question.