Java class not found.

Asked by kp93300

Java Plug-in 1.6.0_15
Using JRE version 1.6.0_15-b03 Java HotSpot(TM) Server VM
User home directory = /home/XXXXX
c: clear console window
f: finalize objects on finalization queue
g: garbage collect
h: display this help message
l: dump classloader list
m: print memory usage
o: trigger logging
q: hide console
r: reload policy configuration
s: dump system and deployment properties
t: dump thread list
v: dump thread stack
x: clear classloader cache
0-5: set trace level to <n>

load: class net.Slingshot.Viewer.Viewer.class not found.
java.lang.ClassNotFoundException: net.Slingshot.Viewer.Viewer.class
 at sun.plugin2.applet.Applet2ClassLoader.findClass(
 at java.lang.ClassLoader.loadClass(
 at java.lang.ClassLoader.loadClass(
 at sun.plugin2.applet.Plugin2ClassLoader.loadCode(
 at sun.plugin2.applet.Plugin2Manager.createApplet(
 at sun.plugin2.applet.Plugin2Manager$
Caused by: open HTTP connection failed:
 at sun.plugin2.applet.Applet2ClassLoader.getBytes(
 at sun.plugin2.applet.Applet2ClassLoader.access$000(
 at sun.plugin2.applet.Applet2ClassLoader$
 at Method)
 at sun.plugin2.applet.Applet2ClassLoader.findClass(
 ... 6 more
Exception: java.lang.ClassNotFoundException: net.Slingshot.Viewer.Viewer.class

Question information

English Edit question
Ubuntu firefox-3.5 Edit question
No assignee Edit question
Solved by:
Mark Rijckenberg
Last query:
Last reply:
Revision history for this message
Best Mark Rijckenberg (markrijckenberg) said :

This is because the file is not found on the webserver. I also get a similar error if I use Firefox to browse directly to the following URL:

Then the webpage gives the following error:

"File not found

This service is currently unavailable. Please contact our Call Centre at 1800 538 9889 for assistance.

Go back and try again "

So I think this is something for the webmaster of that website to sort out, not you.

Revision history for this message
kp93300 (kp93300) said :

Thanks Mark Rijckenberg, that solved my question.